Issues forwarding hunt group to blast group

Unanswered Question

Hi guys,

Last night, I tried replacing some of our shared lines with blast groups. Currently, our UC520 is set up with hunt groups that first ring a single phone, then ring a shared line and finally ring the original person, forwarding to voicemail if not picked up.

This system is inefficient as only 1 call can be on the shared line at one time.

I created a blast group last night with 3 phones added (using the CCA v2) which added the following code,

"voice hunt-group 1 parallel
final 101
list 924,925,951
timeout 5
pilot 507
"

That works fine. I then created a hunt group which would ring a single phone then end on a blast group (it seems like hunt groups can't do Single phone->Blast group-> single phone in a single hunt) which gave me this,

ephone-hunt 5 sequential
pilot 805
list 925
final 507
preference 0 secondary 7
timeout 8
!

Ringing the blast group directly works fine but when we tested ringing 805, it failed when it was supposed to ring the blast group. We checked over the settings for a good few hours, trying to work out why this didn't work but we didn't get anywhere.

This seemed like the logical way to me but is there another way I should be going about this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Hi,

Are you suggesting that I create a dummy ephone to forward all calls for the hunt group?

Why is my current hunt group not working though?  'No Answer Forward to" is set to "Blast Group:1(507)" within CCA and I am able to call the blast group directly. Why does it fail when it tries to forward to the blast group?

Marcos Hernandez Tue, 06/30/2009 - 18:34

That is a limitation in CME and we need better error checking in CCA, which we will be adding.

Thanks,

Marcos

Marcos Hernandez Tue, 06/30/2009 - 18:52

We will probably fix it, but there are no estimates as to when that will happen.


To implement the workaround, please do this:

1) Identify an available out of band ephone-dn. OOB rules for CCA can be found on:

https://supportforums.cisco.com/docs/DOC-9809

2) Enter this CLI. Notice "XX" corresponds to the DN you identified in step 1.

ephone-dn XX

  number 800

  call-forward all 900

In this example, the first hunt group points to 800, which will hit ephone-dn XX, and the call will be forwarded to 900, which corresponds to the pilot number of the second hunt group.

Let me know how this goes.

Marcos

Even using this method, it seems I can't get a hunt group to successfully forward a call to the blast group. Set up ephone-dn 166 which a number of 998 with forwards all to the blast group. Ringing 998 works fine but i added 998 as 'other' in the no answer forward to section and that had the same issue as forwarding directly to the blast group.

Is there any other way to produce the same effect (i.e. hunt group ending up at a blast group)

Marcos Hernandez Tue, 06/30/2009 - 20:06

Can you post your full configuration and version? Don't forget to hide the passwords. Forwarding to a blast group is supported.


Thanks,


marcos

Marcos Hernandez Tue, 06/30/2009 - 20:58

My previous statement was backwards (sorry, I am sleepy). The timeout needs to be lower than the call forward settings of the ephone-dn's in the group. Again, sorry for the mess.

Time for debugs. For a failed call, please provide a "debug voip ccapi inout"

Thanks,


Marcos

Marcos Hernandez Tue, 06/30/2009 - 22:05

Please remove this command from under telephony-service (just negate it):

call-forward system redirecting-expanded

Thanks,


Marcos

Ran the command,

"and-ucncle02(config)#telephony-service

and-ucncle02(config-telephony)#no call-forward system redirecting-expanded

and-ucncle02(config-telephony)#exit

and-ucncle02(config)#exit"

and it still had issues. Tried remaking the blast group(508) and hunt group(808) but it didn't work here. Also didn't work ringing a line (997&998) that was set to forward to it. Attached the current running config.

Attachment: 
Marcos Hernandez Tue, 06/30/2009 - 22:54

Let's try one more thing before we send you to TAC. Try to increase "max-redirecct" under telephony-service to 10.


Thanks,


Marcos

Marcos Hernandez Tue, 06/30/2009 - 22:57

After the redirect from the ephone-hunt, the call gets disconnected with cause code 1, which is unallocated number. The weird thing i that your patterns are all dialable...

Marcos

m-ketchum Wed, 07/01/2009 - 09:10

The following doesn't solve the hunt-group nuances however it may give you the fuctionality that you are looking for.

Keep your current call flow, but reconfigure your shared line as an octal line.  Octal lines have an 8 call limit, so your users will now be able to field multiple calls on the shared line.


www.ketchumits.com

Marcos Hernandez Fri, 07/03/2009 - 08:44

Brent,

I am sorry if I wasn't clear. You need to open a TAC case and have one of our support engineers work with you directly.

Thanks,


Marcos

Actions

This Discussion

Related Content