ASDM Fails to open

Unanswered Question
Jul 2nd, 2009

Hi All,

We have a problem using the ASDM to managae our ASA'S. It stopped working suddenly and everytime we try to use it will stop after trying to load the current configuration.

I have tried clearing the ASDM cache and internal log buffer but still no luck. tried from different computers no difference. Have tried rebooting the unit. ssh works fine. Have trouble only with fetching the running configuration from the unit.

Please give some inputs on this.

Thanks in advance,


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
kyleharris Thu, 07/02/2009 - 09:54


Are you sure that you ASDM versions are in agreement and that the ASDM version in the flash is the same that is being invoked as part of the configuration?

subra4u Fri, 07/03/2009 - 00:57


Thanks for the quick response.

The ASDM version in the unit is asdm506.bin and we downloaded the same version from the ASA.



sudeep.patil Fri, 07/03/2009 - 01:12

hi check with the Java installed ..if the Java has got updated recently automatically .Remove Java update 11 from the add/remove programs .

mgontarczyk Fri, 07/03/2009 - 02:07


Check uptime and version of ASA software - maybe this is the 1 year uptime bug. As I remember that bug was in ASA 8.0.3 software - only reload of the ASA helps.

Also you can check Java console when you load ASDM if you see something like this:

ASDM: java.lang.NumberFormatException: For input string: "1 year 0".


ASDM cannot be started after the ASA's lifetime exceeds one year with the following Java errors:

This the bug: CSCsr89144:

Kureli Sankar Sat, 07/04/2009 - 07:21

He mentioned he already reloaded the ASA.

Try to change the port and see if that works.

no http server enable

http server enable 4443

http 0 0 inside

then use a computer off the inside and connect to


Give that a shot.

As always make sure the java is updated and that you are running the latest ASDM for the code that the ASA is running.

Pls. check this link:

BrinksArgentina Mon, 07/06/2009 - 10:10

Update the ASDM image. I use 6.1(5)57. Older versions don't work with new java.


Please rate all the helpful comments.


This Discussion