Another NOOB VLAN Question

Answered Question
Jul 2nd, 2009

Hello Everyone,

I am working on getting 2 older 2924 switches configured to play around with. I have some VLANs setup but had a few questions.

1) I have the switches connected on Fa0/24 on each switch. How do I configure them to allow the VLAN traffice to pass between each switch? Is Switchport mode trunk sufficient or do I need to make it part of a VLAN as well?

2) I can;t seem to assign an IP address to the switch itslef. Do I just assign an IP address to the management VLAN instead?

Thanks in advance! All replies rated!

I have this problem too.
0 votes
Correct Answer by John Blakley about 7 years 5 months ago

Try the following on both switches:

int fa0/24

switch trunk encaps dot1q

switch mode trunk

switch trunk allowed vlan add 1,2,3 or

2. This is a layer 2 switch, you the only address that you can have is the management address on vlan 1. You can change the management vlan, but for starters it's on vlan 1 and define a gateway if needed:

int vlan 1

ip address 192.168.1.2

ip default-gateway 192.168.1.1

HTH,

John

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
John Blakley Thu, 07/02/2009 - 11:54

Try the following on both switches:

int fa0/24

switch trunk encaps dot1q

switch mode trunk

switch trunk allowed vlan add 1,2,3 or

2. This is a layer 2 switch, you the only address that you can have is the management address on vlan 1. You can change the management vlan, but for starters it's on vlan 1 and define a gateway if needed:

int vlan 1

ip address 192.168.1.2

ip default-gateway 192.168.1.1

HTH,

John

xcz504d1114 Thu, 07/02/2009 - 12:08

Using "switchport mode trunk" is sufficient, depending on IOS and model, you might need to specify the trunk encapsulation first by using "switchport trunk encapsulation dot1q".

By default all VLAN's are allowed on a trunk port.

With a 2924, I believe only one VLAN can be active at a time, which is the management VLAN. You can change the management VLAN in the vlan configuration mode.

HTH,

Craig

Leo Laohoo Thu, 07/02/2009 - 14:24

This is just a small thing ... But you're dealing with the 2900XL/3500XL. So you need to create the VLANS in the VLAN Database in enable mode:

vlan database

vlan 2

exit

I agree, by default if you enable VLAN Trunking, ALL VLANS are allowed.

Hope this helps.

Actions

This Discussion