OffNet Call drops when forwarded from G711 to G729

Unanswered Question
Jul 3rd, 2009

Dear all,

We have a problem with offnet call transfer between regions with different codec.

The system:

- We have a CUCM 6.1 and a CUBE with 12.4.(24)T1. The CUBE connect the network to a SIP provider. Between CUCM and CUBE there is a SIP trunk too.

- We have two different regions one is G711 enabled and the other one is G729 audio codec enabled between region.


When I start a new offnet call from a g729 capable phone, I can transfer it to the other one that is both G711 and G729 capable. But the other way does not work, I cant transfer from G711 region to G729.

When I checked the logs I found that when the transfer occurred CUBE sends BYE message because it receives an SDP from the provider and it contains only G711, (of course because the call was G711 before)

Is there any way to force the CUCM to send the final Invite with SDP contains G729? Only this delayed media work? Can we tell on the CUCM to offer SDP that fits for the phone?

MTP on the trunk not helped.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)

You have posted in the Contact Center forum - are you using CVP?

I don't know exactly what you are doing here, but we have worked with SIP trunks into CVP and I am not surprised. Mixing codecs caused all sorts of problems.

You really need exact advice from Cisco experts who are familiar with the CUBE. You can go around and around on this and drive yourself crazy. I strongly suggest opening a TAC case to see if what you are doing is supported.



zsokg Thu, 07/09/2009 - 06:17

Thanks for the reply.

I hope my soulution does not need any DSP. I do not hawe any E1 connection or T1.

This is a clear SIP solution.

Provider -SIP- CUBE -SIP- CUCM -SIP-CISCO IP phone.

I do not want to transcode, I would like to change the codec from G711 to G729 when transfer occured. (And it needed.)



This Discussion