Disabling HTTP access on a 3825 router?

Unanswered Question
Jul 3rd, 2009
User Badges:

I have tried to enter the "no ip http server" command and the "no ip http secure-server" commands and I still see http connection is enabled on the router, see below:


HTTP Client Connections:

========================

Persistent connection = enabled

Initial socket connection timeout = 5 secs (default)

Connection idle timeout = 2 secs (default)

Total HTTP server connections = 0


Can anyone provide feedback on how to disable http access on the router?


Please let me know!


Thank you.


Rgds,

Vicky

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
paolo bevilacqua Fri, 07/03/2009 - 11:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try connecting. Display output may be irrelevant.

thotsaphon Fri, 07/03/2009 - 11:31
User Badges:
  • Gold, 750 points or more

Vicky,

You did the right things. (grin) If you want to check it please use a "show ip http server all" command. You will see some thing like this HTTP server status: Disabled.



HTH,

Toshi

Giuseppe Larosa Fri, 07/03/2009 - 11:31
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Vicky,


>> Total HTTP server connections = 0


Have you tried to access the router admin page?

Is it still reachable or not ?

if not the show command provides parameters for http client connections but it is a different matter.


Another note is about SDM:

have you used SDM on it?


This could need additional / different commands to disable http/https access


Hope to help

Giuseppe


thotsaphon Fri, 07/03/2009 - 11:33
User Badges:
  • Gold, 750 points or more

Hi Guys,

Vicky typed a "sh ip http client" command. That won't tell you what you want.


HTH,

Toshi

victoriabardy Fri, 07/03/2009 - 16:07
User Badges:

Hi Giuseppe,


I gave this a try and the router was un-reachable. Thank you for your help!


Rgds,

Vicky

Lucien Avramov Sun, 07/05/2009 - 14:31
User Badges:
  • Red, 2250 points or more

no ip http server and no ip http secure-server are enough to disable http on the router.

If you still have doubts, you may want to apply an ACL that matches http traffic and log it. That will proove you that http is no longer working once the above commands are entered.

Actions

This Discussion