1841 router behind a DSL modem in bridge mode as a PPPoE client

Unanswered Question
Jul 3rd, 2009

I have setup a configuration for a 1841 router to connect to the ISP using a dsl modem in bridge mode. I use my computer connected to the dsl modem in bridge mode and it works using windows xp pppoe client perfectly. But the router doesn't connect. This is the setup i'm using:

!

vpdn-group 1

request-dialin

protocol pppoe

!

interface FastEthernet0/1

description WAN Interface

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname <<Username>>

ppp chap password 7 <<Password>>

ppp pap sent-username <<Username>> password 7 <<Password>>

ppp ipcp route default

ppp ipcp address accept

ip route 0.0.0.0 0.0.0.0 Dialer0

any help will be appreciated. The debugs only show sending PADR. But I know the dsl modem is working because with the pc using windows pppoe client I can connect well.

Regards,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sat, 07/04/2009 - 02:09

Maybe you need to clone the MAC from the PC, or ask ISP to release whatever MAC reservation.

In any case, it would be better for you to use an ADSL model like an 871 or 1801.

Jose Robles Mon, 07/06/2009 - 06:07

This are the debugs and the output of them. These is all I'm seeing. I opened a TAC case and the engineer confirmed the configs are ok. The weird thing is that with my pc works fine every time so I have nothing to say to the ISP.

Router# sh debugging

PPPoE:

PPPoE protocol events debugging is on

PPPoE data packets debugging is on

PPPoE control packets debugging is on

PPPoE protocol errors debugging is on

PPPoE elog debugging is on

PPP:

PPP authentication debugging is on

PPP protocol negotiation debugging is on

Log Buffer (2000000 bytes):

*Jul 3 15:36:34.235: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern et0/1, changed state to up *Jul 3 15:37:01.575: padi timer expired *Jul 3 15:37:01.575: Sending PADI: Interface = FastEthernet0/1 *Jul 3 15:37:01.575: pppoe_send_padi:

FF FF FF FF FF FF 00 24 C4 87 75 CD 88 63 11 09

00 00 00 0C 01 01 00 00 01 03 00 04 63 5E 34 2C ...

*Jul 3 15:37:01.615: PPPoE 0: I PADO R:0090.1a42.157a L:0024.c487.75cd Fa0/1

00 24 C4 87 75 CD 00 90 1A 42 15 7A 88 63 11 07

00 00 00 84 01 02 00 0F 4A 55 4E 43 41 50 2D ...

*Jul 3 15:37:03.623: PPPOE: we've got our pado and the pado timer went off *Jul 3 15:37:03.623: OUT PADR from PPPoE Session

00 90 1A 42 15 7A 00 24 C4 87 75 CD 88 63 11 19

00 00 00 84 01 02 00 0F 4A 55 4E 43 41 50 2D ...

*Jul 3 15:37:13.863: OUT PADR from PPPoE Session

00 90 1A 42 15 7A 00 24 C4 87 75 CD 88 63 11 19

00 00 00 84 01 02 00 0F 4A 55 4E 43 41 50 2D ...

*Jul 3 15:37:13.863: PPPOE : Resending PADR *Jul 3 15:37:24.103: OUT PADR from PPPoE Session

00 90 1A 42 15 7A 00 24 C4 87 75 CD 88 63 11 19

00 00 00 84 01 02 00 0F 4A 55 4E 43 41 50 2D ...

*Jul 3 15:37:24.103: PPPOE : Resending PADR *Jul 3 15:37:34.343: OUT PADR from PPPoE Session

00 90 1A 42 15 7A 00 24 C4 87 75 CD 88 63 11 19

00 00 00 84 01 02 00 0F 4A 55 4E 43 41 50 2D ...

*Jul 3 15:37:34.343: PPPOE : Resending PADR *Jul 3 15:37:44.583: OUT PADR from PPPoE Session

00 90 1A 42 15 7A 00 24 C4 87 75 CD 88 63 11 19

00 00 00 84 01 02 00 0F 4A 55 4E 43 41 50 2D ...

*Jul 3 15:37:44.583: PPPOE : Resending PADR *Jul 3 15:37:45.403: %SYS-5-CONFIG_I: Configured from console by console *Jul 3 15:37:54.987: OUT PADR from PPPoE Session

00 90 1A 42 15 7A 00 24 C4 87 75 CD 88 63 11 19

00 00 00 84 01 02 00 0F 4A 55 4E 43 41 50 2D ...

*Jul 3 15:37:54.987: PPPOE : Resending PADR *Jul 3 15:38:05.227: PPPoE : Shutting down client session *Jul 3 15:38:05.227: [0]PPPoE 0: O PADT R:0000.0000.0000 L:0000.0000.0000 Fa0/

1

00 00 00 00 00 00 00 24 C4 87 75 CD 88 63 11 A7

00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ...

*Jul 3 15:38:05.227: PPPOE : Resending PADR Router#

Paolo Bevilacqua Mon, 07/06/2009 - 06:44

As mentioned before: ISP may have cached PC MAC address and ignoring requests coming from other MACs.

Actions

This Discussion