spa3102 - red - green blinking power light

Unanswered Question
Jul 3rd, 2009

Hello,

I have an spa3102 that was working fine for some time.  Just today I tried to change my dial plan, and after saving the settings, it never came back up.  Instead, it now blinks the following sequence - 1 long red flash, 4 medium green flashes, and repeats.  It does not seem to be responding to IVR or the web interface, and the phone jack remains connected to the analog line.  What could have happened, and is there anything I can do to fix this? 

Thanks,

- Babu

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Mon, 07/06/2009 - 07:04

Dear Sir;

Could you try disconnecting PSTN and WAN, power cycle and try accessing IVR or web interface? It may be cause by different reasons.

If you are able to get to the IVR (****) then my suggestion is to apply a factory reset.

Regards
Alberto

babu-pillai Wed, 07/08/2009 - 08:22

Hello Albert,

I am not able to get to the IVR menu, even with the PSTN and WAN wires disconnected.  Is there something else I can try?

Thanks,

- Babu

amitsood1 Sun, 07/26/2009 - 03:16

Hi Alberto,

I am having similar problem. How should I recover it from auto reboot? The reboot cycle goes on.

The tool you attached can only be used if I know the IP Address. Any help?

regards,

-amit-

Alberto Montilla Tue, 07/28/2009 - 08:46

Hi Amit;

The tool attached above requires serial number only, not IP address. Make sure you are connected to the same LAN to the device. It should recover.

Regards
Alberto

babu-pillai Sun, 08/23/2009 - 09:52

Hi Alberto,

The tool you sent did not work for me (at least at first).  My unit was not even enabling the ethernet ports (I could tell because no link light on any switch I connect to either port, and if I connect directly to a PC, the PC never detects that a cable has been connected).  I guess it was rebooting before it got that far.

Anyway, I eventually found a way to get it to the state where it was blinking the SOS sequence and enabling the ethernet ports.  At this point, the tool you sent half worked -- it found the device and downloaded firmware, but then got an error saying it couldn't bind to the http server.  The device went into another bad state -- very slow blinking of a red status light, and no ethernet ports active, no IVR.

I was able to get it back to SOS mode, and tried again -- but got the same results. Back to slow red blink, no ethernet or IVR.  Could there be a mismatch between my hardware version and the new firmware?  ( I have HW rev 1.45(a), and used to have SW version 3.3.6(GW) )

Is there something else I can try, or am I using the tool incorrectly?

Thanks,

- Babu

Patrick Born Mon, 08/24/2009 - 15:55

Hi Babu,

Make sure that your computer does not have any firewall or anything enabled that will prevent full communication between the SPA3102 and the application running on your computer.

Perhaps try using a different computer or simplifying your network by making sure that the computer and SPA3102 are on the same LAN on the same switch.

Regards,

Patrick

----------

fernandolordao Sat, 01/16/2010 - 06:46

My SPA3102 is in the same problem since yesterday.

The ETHERNET PORT HAS NO SIGNAL/power. When I connect the SPA to the router, the router's led does NOT light, like NO DEVICE WAS CONNECTED.

I have already tested in two different routers. I have tested directly to the PC ethernet port, but no sucess until now.

The PHONE PORT HAS NO SIGNAL/power too. When I connect the telephone, I have NO DIAL TONE.

So, I have no ways to connect the device. No ethernet, neither telephone. No IP Address and no Interective Voice Response (IVR) menu.

Is there SOME OTHER WAY TO RESET this device?????

Thanks,

Fernando.

Brazil

Attachment: 
babu-pillai Mon, 01/18/2010 - 13:55

Hi Fernando,

Yes, I had a similar problem to you, but my blink pattern was a bit different.  The router kept rebooting before the phone or ethernet were intitialized.  I was able to revive my system, but required some minor hacking.  I DO NOT RECOMMEND FOLLOWING.  IT WILL VOID ANY WARRANTY, MAY DESTROY YOUR DEVICE, AND MAY BE A FIRE OR SHOCK HAZARD.  However, it did revive my system. If you are daring or desperate enough, here is what I did.

First, here is what I think was wrong with my system:  I think the firmware was fine, but somehow the saved settings were corrupted when I last changed them through the web interface.  So the boot loader sees that the firmware is good, so it does not enter the SOS mode; instead the firmware starts, and then it hangs due to the corrupted data, before the Ethernet or phone are initialized.  Then some watchdog timer or interrupt causes a reboot.

So what I did was open up the case (screws are under the rubber feet, which are just glued in place), and find the flash chip.  Sorry, I don't have pictures.  It is a flat chip that is approximately 2 cm by 1 cm, with pins on the short sides.  I used a small screwdriver to short some pins together momentarily while the system was booting to introduce data errors.  Note: I did not continuously hold the screwdriver on the pins -- I just briefly touched them.  I don't remember which pins -- you should be able to find a datasheet online somewhere that shows which are the data and address pins.  Any of these should work.  Actually, in my later attempts tofix this, I was poking the pins somewhat randomly, so any pins ought to work -- just don't short power and ground (Again, look up the datasheets online if you want to be sure).

So here is the process I followed.  As the system ran through its repeated reboots, I poked at the flash chip pins.  If I poked too early, the boot loader is corrupted and the system won't do anything any more (leds stop blinking) until it is power cycled.  If I poked too late, nothing is being read from flash so there is no effect and the reboot cycle is unchanged.  If I get it just right, soon after the red led turns on, when the bootloader is reading the firmware, but before the firmware is run, the bootloader sees a corrupt firmware and goes into the SOS mode, with a working ethernet port.  Then the tool from Cisco will work to load a new firmware. If after loading the new firmware, the system boots, then you are done!

Unfortunately, that didn't fix my system.  The new firmware would load, and the corrupt data would cause it to reboot as well, except the blink pattern it generated was a bit different.  What I needed to do was get the firmware to load, but the data not to load.  I tried poking the pins at different times in the reboot cycle.  I think if you hit it at just the right time, about when the red light is going to change, the firmware will boot (and not reset or go into SOS)!!  (The timing may be a bit different for you, though since your blink pattern is different).  I had to try a lot of times to get this right (it would often do nothing or go into SOS mode).  If it does come up, immediately do a factory reset!  This will clean up whatever junk was in the data area that caused the reboots.

After that, hopefully, your system will be as good as new!  Mine is just fine -- even the rubber feet are back in place!  Good luck!

- Babu

amitsood1 Fri, 01/22/2010 - 20:21

Wow! That is cool Babu. Would be able to tell us the chip number or some identification.

cheers,

-amit

fernandolordao Sat, 01/23/2010 - 09:46

Hi Babu!

The procedure you described is, in fact, a real surgery. :-)

But, as I bought that device only one month ago, I used the warranty from my local retailer.

I hope not have to do this surgery in the future.

Thanks all your attention,

Fernando Lordao.

Actions

This Discussion