Remote office phone not connecting with UC520

Unanswered Question

Scenario is as follows:

UC520 with internal phones DHCP scope of 10.1.1.X (main unit 10.1.1.1) and LAN (data network) of 10.3.2.X/24. The WAN port of the UC520 is connected to the office LAN - data network is VLAN1 and voice network is VLAN100.

Default gateway on office LAN is 10.3.2.254 on ASA5505 with a VPN connection to remote office where there's a 877W router terminating the VPN (remote office subnet is 10.2.10.X/24).

Cisco 7960 phone connected to the 877W (by UTP) gets an IP via DHCP from this router. Option 150 is set to the UC520 LAN IP at the main office (10.3.2.10) and this IP is reachable from the remote office.

The phone boots, gets an IP and knows it needs to talk with UC520 phone for TFTP on 10.1.1.1 - this shows as the phone boots (have also reset phone to factory defaults).

When the phone boots it comes up with an error saying it can't find the configuration file from the TFTP server and I believe it's not actually able to connect with 10.1.1.1 at the remote site despite putting route statements into router/ASA5505/UC520 for the different networks.

So - are there any configs & can see or any recommendations for how to get a phone at a remote office to connect with the UC520 at head office over a Cisco VPN tunnel?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Sat, 07/04/2009 - 04:28

Can you ping phone from cme ?

If you can't, you need you VPN fixed.

Often this is better done without any ASA as these are capricious units, routers are much easier and predictable.

I can ping the phone from the main LAN - both from a Windows terminal server and from the UC520 itself (by telnetting into the LAN address).

My suspicion is I've assigned the LAN address (10.3.2.10) of the UC520 as option 150 to the phone but when it boots it wants to TFTP connect to 10.1.1.1. I need the UC520 to deliver the TFTP information back out through the LAN address instead.

It's a bit tricky for me to remove the ASA from the equation but I'll certainly keep it in mind.

Paolo Bevilacqua Sun, 07/05/2009 - 01:35

Correct, you need always and everywhere the CME address as option 150.

If phone doesn't use it check that it is not statically configured.

Actions

This Discussion