OffNet Call drops when forwarded from G711 to G729

Unanswered Question
Jul 6th, 2009

Dear all,

We have a problem with offnet call transfer between regions with different codec.

The system:

- We have a CUCM 6.1 and a CUBE with 12.4.(24)T1. The CUBE connect the network to a SIP provider. Between CUCM and CUBE there is a SIP trunk too.

- We have two different regions one is G711 enabled and the other one is G729 audio codec enabled between region.

Symptoms:

When I start a new offnet call from a g729 capable phone, I can transfer it to the other one that is both G711 and G729 capable. But the other way does not work, I cant transfer from G711 region to G729.

When I checked the logs I found that when the transfer occurred CUBE sends BYE message because it receives an SDP from the provider and it contains only G711, (of course because the call was G711 before)

Is there any way to force the CUCM to send the final Invite with SDP contains G729? Only this delayed media work? Can we tell on the CUCM to offer SDP that fits for the phone?

MTP on the trunk not helped.

Thanks,

Gabor

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
douhanm Sat, 07/18/2009 - 10:35

As far as I understand this is non supported config, there is no way for UCM to know that it needs to invoke a transcoder, the same issue occurs if you use SIP to integrate UNITY express that resides inside a H.323 GW registred in UCM.

I believe you must make sure that the codecs are consistent in this scneario

Actions

This Discussion