SRW208P Not passing traffic

Unanswered Question
Jul 6th, 2009

I've got a Mitel phone that is stuck in DHCP DISCOVERY. It is located in another building. That building is connected to the main building with a fibre link using a fast ethernet media converter The network map is shown below.

I have tried other phones and they dont work however if I take the phone back into the office it works fine.

I've called Mitel themselves and they have no idea what could be causing this. HP advised to try turning spanning tree off but this is all to no avail. The only other intelligent device in between is the Linksys SRW208P. I have upgraded the firmware, reset to factory defaults with no success.

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chrcoope Mon, 07/06/2009 - 06:15

If I am understanding your diagram correctly it indicates that the PC (on the linksys switch at the top of the diagram) is receiving DHCP fine? Have you tried plugging that phone into that switch port and vice versa? Since it can receive DHCP when plugged into the ProCurve I am reluctant to suggest that it might be tagging itself. I am not sure wether or not the ProCurve can dynamically set its port though so I thought I would at least mention it. If you have not already, I would turn spanning tree back on. Perhapse you could mirror the switchport the phone is plugged into and do a packet capture of segment and attach that to this post.

chrcoope Mon, 07/06/2009 - 16:38

The phone receives an offer for 192.168.3.2 /24, default gateway 192.168.3.1, DNS servers 192.168.1.1 and 192.168.1.5, wins 192.168.1.5 and was issued by 192.168.3.1. Does this sound correct? There are multiple networks operating on your infrastructure. Are you using VLAN's? 192.168.3.3 looks like a workstation. Can this workstation get to the Internet with this IP address configuration when plugged into the switch?

Something you might also try is Increase Port Broadcast Control threshold to 300 Kbps if it is available.

trinomhota Tue, 07/07/2009 - 03:27

You wont believe this. My schoolboy error, I swapped the switch ports, patch panel port, ethernet converter and the switch itself, in all cases. Only the PC got an address. All the while I was not swapping the ETHERNET CABLE! Although the phone was coming on and displaying its progress then being stuck on DHCP Discovery I had not at any one point thought they'd be something wrong with the cable itself!!

Actions

This Discussion