Cisco 857 not working since ADSL2 upgrade

Answered Question
Jul 6th, 2009
User Badges:

Hi,


I have a Cisco 857 router. Recently the ISP (BT) have upgraded the ADSL line to ADSL2. Since then, the router is unable to obtain an internet connection. The CD light flashed constantly, and the PPP light never comes on solid.


There have been no changes to the router config. I tried resetting the router to factory defaults, then giving the router a basic config, but I still get the same result.


My ADSL settings:

Enc: PPPoA(AAL5MUX)

VPI: 0

VCI: 38

Address: IP Negatiated

Authentication: Chap & Pap


As a test, I swapped the Cisco 857 for a Netgear 834, and the Netgear connected straight away.


Can anyone suggest anything I can try?


Thanks


Nick

Correct Answer by Giuseppe Larosa about 7 years 8 months ago

Hello Nick,


try the following to download an updated firmware


Try:


ftp://ftp.cisco.com/pub/access/800/


What you want is 3-0-33 FW.


Thanks to Paolo Bevilaqua


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
thotsaphon Mon, 07/06/2009 - 09:03
User Badges:
  • Gold, 750 points or more

Nick,

It does support.

http://www.cisco.com/en/US/prod/collateral/routers/ps380/ps6200/prod_qas0900aecd8028a982.html



Q. Do the platforms support ADSL2/2+?

A. The Cisco 857, 876, 877 and 877M routers support ADSL2/2+ standards.



Please let me know which ios version you're using and the output of "debug pppatm error". It's good to see your configuration.


HTH,

Toshi



nickc1976 Wed, 07/08/2009 - 07:13
User Badges:

Hi,


Thanks for your assistance.


IOS version is 2.4


I entered the command "debug pppatm error", and the message "PPP over ATM errors debugging is on" is displayed. But no debug information was shown. Do I need to enter another command to view the output?


Nick

Giuseppe Larosa Wed, 07/08/2009 - 11:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nick,

post

sh dsl interface atm0


to be noted:

if the provider DSLAM has been upgraded to ADSL2 it can be a problem because ADSL2+ is backward compatible with ADSL but ADSL2 isn't.


Hope to help

Giuseppe


Giuseppe Larosa Fri, 07/10/2009 - 05:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nick,

as I've suspected there is incompatibility.


you probaly need a firmware upgrade to achieve a working link.


the easiest way to do this is to load a newer IOS image like 12.4(20)T or later.


Edit:

if you look in the forum archive you can find the procedure and the link to download newer firmware.



Hope to help

Giuseppe


nickc1976 Fri, 07/10/2009 - 05:43
User Badges:

Thanks Giuseppe.


Can I download the latest IOS from this website?


Nick

nickc1976 Fri, 07/10/2009 - 06:09
User Badges:

Thanks. I will check it out and let you know how it goes.


Nick

thotsaphon Fri, 07/10/2009 - 06:18
User Badges:
  • Gold, 750 points or more

Nick,

Sorry for replying too late. I got a long weekend. As Giuseppe mentioned, you may try to upgrade your ios. However you need to have CCO to access this software. If you've purchased the service you can request user/password from the vendor.


Toshi

nickc1976 Wed, 07/15/2009 - 06:08
User Badges:

Hi,


I am struggling to find how to download the software. This is what I have done so far.


http://cisco.com


"Products and Services"


"Cisco IOS and NX-OS Software"


Cisco IOS Software Releases > Cisco IOS Software Release 12.4T


Support > Download Software


Log in


Download Software > Select a product

Routers > Cisco 800 Series > Cisco 857 Integrated Services Router


Select a release

Latest Release > 12.4.15T9(MD)


Select the link to the file at bottom of page


"To download this software, you must do all of the following:


Register

Due to United States export compliance regulations, you must be registered on Cisco.com to download this software. If you do not have a Cisco.com username and password, please register now. Registration is free. If you have already registered, please log in to proceed."


I am already logged in!


If I select Log in now, I am returned to the previous page!

Giuseppe Larosa Wed, 07/15/2009 - 22:50
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nick,

the CCO account has to be associated to a service contract to be able to download the IOS image.

Contact who has sold you the router.


your account has not enough rights at the moment.


Hope to help

Giuseppe


Correct Answer
Giuseppe Larosa Fri, 07/17/2009 - 01:55
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nick,


try the following to download an updated firmware


Try:


ftp://ftp.cisco.com/pub/access/800/


What you want is 3-0-33 FW.


Thanks to Paolo Bevilaqua


Hope to help

Giuseppe


nickc1976 Sat, 07/18/2009 - 05:55
User Badges:

Hi,


Thanks for the link. I downloaded the file adsl_alc_20190.3-0-33.bin


Next I used the command "copy tftp flash" to update the router. I have attached the results - is this correct?


I will test this at the affected office on Monday and post back the results.


Nick



Attachment: 
Giuseppe Larosa Sat, 07/18/2009 - 11:10
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Nick,


I give you the link to a similar thread in WAN forum


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&topicID=.ee71a06&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cd29d74


where Andrew explains the file has to be in flash and has to be renamed to the name the router looks for at boot time.


Here are the Andrew's words


You can also independantly load ADSL firmware outside of the IOS image by copying the firmware file to the flash and renaming it to 'adsl_alc_20190.bin'. During the IOS boot the router checks for this file in flash and if it is there loads this instead of the one embedded in the IOS image. The latest firmware for the ADSL modem in the 857/877 is version 4.0.15 and is available here:

http://www.cisco.com/cgi-bin/Software/Tablebuild/doftp.pl?ftpfile=/cisco/access/800/adsl_alc_20190.bin.4.0.15


Hope to help

Giuseppe




nickc1976 Mon, 07/20/2009 - 03:24
User Badges:

Hi Giuseppe,


I renamed the file to adsl_alc_20190.bin, then copied it to the router, and this has now resolved the issue. Thank you for all your help.


Just out of interest, is there a way to remove this file once it has been copied to the flash?


Nick

Actions

This Discussion