WAN Advertisement via MPLS VPN

Unanswered Question
Jul 6th, 2009
User Badges:

Hello Guys -


How are you guys.. Apprently i am having some issues with router advertisements to our MPLS cloud.


Diagram :




MPLS Cloud

^^^^

PE C:PE MPLS router

^^^^

CE B: Main Core router switch

^^^^ (point to point ip connection - /30)

CE A: Prestaged Core Switch (Interface vlan:10.106.140.0/25 and 10.106.140.128/25)


-----------------------

Configurations:


CE A:

!

interface Vlan110

ip address 10.106.151.254 255.255.254.0

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface Vlan200

ip address 10.106.140.126 255.255.255.128

no ip redirects

no ip unreachables

no ip proxy-arp

!


CE B:

!

router bgp 65096

no synchronization

no auto-summary

redistribute static route-map RMAP-1820

!

ip route 10.106.140.0 255.255.255.128 10.0.0.2

ip route 10.106.140.128 255.255.255.128 10.0.0.2

!

access-list 99 deny any

access-list 1820 permit 10.106.140.0 0.0.0.127

access-list 1820 permit 10.106.140.128 0.0.0.127

!

route-map RMAP-1820 permit 10

match ip address 1820

!



PE C:

!

ip prefix-list TF-ROUTES

ip prefix-list TF-ROUTES seq 130 permit 10.106.140.0/22

ip prefix-list TF-ROUTES seq 120 permit 10.106.144.0/21

!

address-family ipv4 vrf ENT-ROUTES

neighbor x.x.x.250 remote-as 65096

neighbor x.x.x.250 description MNL3-CE1

neighbor x.x.x.250 activate

neighbor x.x.x.250 soft-reconfiguration inbound

neighbor x.x.x.250 prefix-list TF-ROUTES in

no synchronization

exit-address-family

!



I appreciate your help.


Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 07/06/2009 - 13:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Jose,

unless you have forgotten to report in your post CE B is missing the neighbor command under the router bgp process.


CE B

router bgp 65096

neigh x.x.x.249 remote-as pe-AS-number


Hope to help

Giuseppe


Actions

This Discussion