Error: Unable to retrieve active partition information

Unanswered Question
Jul 6th, 2009
User Badges:

Hi,

I have this error window in DFM (3.1)when I tried to open any option; Device Management or Notification Services.

"unable to retrieve active partition information"

Before this, sent me a message windows where said that read nos.log, but it's so large and I don't understand the solution.

How can I resolve the problem? Is there any procedure to correct the corruption Database or something like a maintenance for this?

LMS 3.1 on Windows Server 2003


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 07/06/2009 - 14:42
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Exactly what version of DFM do you have? Post the output of the pdshow command, then compress the nos.log, and post it as well.

Joe Clarke Tue, 07/07/2009 - 11:08
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

It looks like you have a problem with your DFM databases. If you have a known good backup of LMS, try restoring it. If not, try reinitializing your DFM databases with the commands:


NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=dfmInv dmprefix=INV



NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=dfmFh dmprefix=FH



NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=dfmEpm dmprefix=EPM


Then delete NMSROOT/objects/smarts/local/repos/icf/DFM*.rps.

Emonroy89 Tue, 07/07/2009 - 14:38
User Badges:

I reinitialized with the commands but now when I tried to open Device Management's menu, open http page error or the same error, furthermore I can't do immediate backup in CS. I have backups of last week (sheduled with CS->Server->Admin->backup) but I don't known who restore it.

Can you help me?

Joe Clarke Tue, 07/07/2009 - 15:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What HTTP error do you get? As for the backups, you'll need to start a new thread for that.

Emonroy89 Wed, 07/08/2009 - 08:08
User Badges:

HTTP Status 500 -

--------------------------------------------------------------------------------

type Exception report


message


description The server encountered an internal error () that prevented it from fulfilling this request.


exception


java.lang.NullPointerException

com.cisco.nm.trx.nos.action.NGroup.perform(NGroup.java:141)

org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)

org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)

org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:491)

javax.servlet.http.HttpServlet.service(HttpServlet.java:689)

javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

com.cisco.nm.cmf.util.AccessLogFilter.doFilter(AccessLogFilter.java:100)


note The full stack trace of the root cause is available in the Apache

Tomcat/5.5.17 logs.


Apache Tomcat/5.5.17


I think, It will be better to restore a backup, but I need to check the correct way to do this.


Joe Clarke Wed, 07/08/2009 - 10:20
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Use the NMSROOT/bin/restorebackup.pl script to restore a backup. The exact command line will depend on your platform, the location of your backups, and the generation number to restore. Consult the online help for more details.


However, if you have already reinitialized all of the DFM databases, there is something else wrong here. It would probably be a good idea to contact TAC so live troubleshooting can be done.

Emonroy89 Thu, 07/23/2009 - 07:58
User Badges:

Hello again,


2 things:

1. I restored a backup with restorebackup.pl command

2. TAC suggested me do a manual backup.pl


I did both things and CW operate good for a week with sheduler backup, but now again I have problem with the backup. Today I tried to manual backup and send me; dbeng10-windows error. The manual backup continue and finally finish good (30min aprox).


I have to do something else in my server, I don't like restart it every week, and I don't know how serius error-windows is.


thanks in advance





Actions

This Discussion