Voice and Data Traffic in 3550 Problem

Answered Question
Jul 6th, 2009
User Badges:

Hi Guys,


I have posted a while ago that our IP Phones will not work in Cisco 3500 XL Switch. Someone helped me fix it by configuring to trunk mode the port where I will connect the IP Phone.


Now my other problem is that we share voice and data traffic on the same port and since the port is already configured to trunk mode it will not let data traffic pass through.


Some suggest to use native vlan for data traffic. But our network is already setup to use vlan 4-10 for end user data traffic and native vlan for Routers and Switches and vlan 2 for servers.


Here is a sample of my config in 3550:


interface FastEthernet0/14

switchport access vlan 10

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 3


Hope someone can help me on this. I need to use vlan 10 for data traffic.


Thanks.



Correct Answer by Jerry Ye about 7 years 8 months ago

Hi John,


Can you try this instead:


interface FastEthernet0/14

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

switchport voice vlan 3


HTH,

jerry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jerry Ye Mon, 07/06/2009 - 17:19
User Badges:
  • Cisco Employee,

Hi John,


I saw your other post which indicated you are using Cisco CallManager. So my assumption is you are using Cisco IP phone. The port configuration should look like the following:


interface FastEthernet0/14

switchport access vlan 10

switchport mode access

switchport voice vlan 3

spanning-tree portfast


HTH,

jerry


helios999 Mon, 07/06/2009 - 17:49
User Badges:

Hi Jeye,


Thanks for the reply.


Yes we are using Cisco Call Manager and Cisco IP Phone 7912.


Regarding your comment I assume I will issue those commands in the Cisco 3500 XL Switch, right?


My only problem is that IP Phones will only work in 3500 XL if the port where it is connected is configured to trunk mode.


I have tried your suggestion but it didn't work. Hope you can give me other options. Thanks.


John



Correct Answer
Jerry Ye Mon, 07/06/2009 - 18:04
User Badges:
  • Cisco Employee,

Hi John,


Can you try this instead:


interface FastEthernet0/14

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 10

switchport voice vlan 3


HTH,

jerry

helios999 Mon, 07/06/2009 - 18:14
User Badges:

Hi Jeye,


Your suggestion solve my problem. I will rate your answer accordingly. Hope you can always answer me if I have questions. Is it ok if I will ask for your email?


Thanks a lot.

Jerry Ye Mon, 07/06/2009 - 18:16
User Badges:
  • Cisco Employee,

Hi John,


You can post it here since I will check the forum couple times a day.


Regards,

jerry

Actions

This Discussion