Qos for remote pppoe connections

Unanswered Question
Jul 7th, 2009

Hi guys

iam trying to do traffic shaping on one of my cisco routers.I have 10 clients connecting to the router via adsl connections and the router is terminating pppoe sessions from clients, forwarding radius requests to the radius server.i have got a 2mbps uplink and would like to rate limit the clients according to the bandwidth they buy from my company.I tried the attached configurations but it doesnt look like traffic is being shaped, even when my uplink is throttled to the limit.if i type command: show policy-map int e0 , no shaping is happening

my clients get virtual access interfaces dynamically and some are hitting more than 1mbps.

Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Tue, 07/07/2009 - 03:22

Other than the bit strange usage of both a policer and shaper in class-default, your policy (itself), at a glance, looks okay. (NB: second glance, I wonder whether your ACLs are matching since NAT is involved.)

Could you post a show policy-map?

What do you mean by ". . . even when my uplink is throttled to the limit."?

Re: clients, how do you know ". . . some are hitting more than 1mbps."?

PS:

You're unable to support full duplex on the uplink?

tonderai.chinowona Tue, 07/07/2009 - 23:00

What do you mean by ". . . even when my uplink is throttled to the limit."?

i mean my uplink is operating at 2mbps(thats my maximum bandwidth.

Re: clients, how do you know ". . . some are hitting more than 1mbps."?

if i do show interface vi2, it shows me the input and output rates for the client connected on the virtual interface

right now i removed nat.Here is my show policy-map

Attachment: 
tonderai.chinowona Tue, 07/07/2009 - 23:10

What do you mean by ". . . even when my uplink is throttled to the limit."?

i mean my uplink is operating at 2mbps(thats my maximum bandwidth.

Re: clients, how do you know ". . . some are hitting more than 1mbps."?

if i do show interface vi2, it shows me the input and output rates for the client connected on the virtual interface

right now i removed nat.Here is my show policy-map

Joseph W. Doherty Wed, 07/08/2009 - 02:49

Sorry wasn't precise, wanted posting of show policy interface, so we can see actual policy map stats.

re: maximum bandwidth, 2 Mbps means little since it's not the physical bandwidth of the interface -- which is why your shapers are important

re: removing NAT - if you need NAT, don't remove it

Joseph W. Doherty Wed, 07/08/2009 - 19:42

The policy is applied to int E0, outbound. The 1.6 Mbps you mention, is inbound, not outbound on interface E0. Outbound shows 566 Kbps, and no active shaping (although stats show there has been shaping). I.e., doesn't show the shaping being over speed for this interface snapshot.

tonderai.chinowona Wed, 07/08/2009 - 22:45

How can i apply it on the inbound of Eth0.If i try inbound on e0, i get an error messege that CBWFQ can be enabled as an outut feature only.

If i apply it on output of f0, everything stops working.All policy maps wont be matched except the default.

Joseph W. Doherty Thu, 07/09/2009 - 03:14

You can apply CBWFQ as inbound, but you're limited to features used (e.g. no queuing [includes shaping]). (Also inbound policing usually can't provide quite the same results.)

You write your policy doesn't match, except default, when applied outbound, yet the information you've posted shows both an outbound policy configuration and it's working (i.e. matching other than default)? What interface do you need to shape, outbound, E0 for FE0? Or, is the issue when NAT is in operation?

If the latter, one alternative is to mark (IP Prec or DSCP) your packets on the ingress interface, then use those markings upon egress interface.

Actions

This Discussion