Cisco Router Multicast Assist...

Unanswered Question
Jul 7th, 2009
User Badges:

Hi all,

Here is the topology:

R9 <----> R8 <----> R7


When I attempt to ping from R7 to 239.0.0.1, I get no responces.


The configurations are below, am I missing something in the configuration?


R9:

interface Loopback0

ip address 3.1.1.1 255.255.255.0


interface FastEthernet0/0

ip address 1.1.1.1 255.255.255.0

ip igmp join-group 239.0.0.1

duplex auto

speed auto


router rip

version 2

network 1.1.0.0

network 3.1.0.0

no auto-summary



R8:

ip multicast-routing


interface FastEthernet0/0

ip address 2.2.2.12 255.255.255.0

ip pim sparse-mode

duplex auto

speed auto


interface FastEthernet1/0

ip address 1.1.1.12 255.255.255.0

ip igmp limit 100

duplex auto

speed auto


router rip

version 2

network 2.2.0.0

network 1.1.0.0

no auto-summary


ip pim rp-address 4.1.1.2



R7:

ip multicast-routing


interface Loopback0

ip address 4.1.1.2 255.255.255.0

ip pim sparse-mode


interface FastEthernet0/0

ip address 2.2.2.2 255.255.255.0

ip pim sparse-mode

duplex auto

speed auto


router rip

version 2

network 4.1.0.0

network 2.2.0.0

no auto-summary


ip pim rp-address 4.1.1.2





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Tue, 07/07/2009 - 11:18
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You need to enable Mcast routing and PIM under the interface on R9 in addition to having the 'ip pim rp-address' info for it to respond to the ping.


You also need PIM enabled on R8's F1/0 interface.


HTH,


__


Edison.

Harold Ritter Tue, 07/07/2009 - 11:41
User Badges:
  • Cisco Employee,

Edison,


You only need the "ip igmp join-group" command if you want R9 to act as a host.


Regards

Edison Ortiz Tue, 07/07/2009 - 12:06
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Harold,


It's one of the oddities when doing Host Mcast on Cisco routers. It won't respond to pings.


I dumped his config on a lab and the mroute table looks at it should, yet the host does not respond to pings:


RP Mroute Table:


(*, 239.0.0.1), 00:00:24/stopped, RP 4.1.1.2, flags: SJCF

Incoming interface: FastEthernet0/0, RPF nbr 2.2.2.2

Outgoing interface list:

FastEthernet0/1, Forward/Sparse, 00:00:24/00:02:35


(2.2.2.2, 239.0.0.1), 00:00:24/00:02:59, flags: FT

Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0

Outgoing interface list:

FastEthernet0/1, Forward/Sparse, 00:00:24/00:02:35


(4.1.1.2, 239.0.0.1), 00:00:22/00:02:59, flags: JT

Incoming interface: FastEthernet0/0, RPF nbr 2.2.2.2

Outgoing interface list:

FastEthernet0/1, Forward/Sparse, 00:00:22/00:02:37



The source sending packets:


R7#ping 239.0.0.1 repeat 10


Type escape sequence to abort.

Sending 10, 100-byte ICMP Echos to 239.0.0.1, timeout is 2 seconds:

..........



If you go to the host, it doesn't know the RP:


(*, 239.0.0.1), 00:01:20/00:02:21, RP 0.0.0.0, flags: SJPL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list: Null


(*, 224.0.1.40), 00:01:20/00:02:23, RP 0.0.0.0, flags: DPL

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list: Null


Now, If I enabled Mcast routing along with PIM on the interface *and* the rp-address static info:


R7#ping 239.0.0.1 repeat 10


Type escape sequence to abort.

Sending 10, 100-byte ICMP Echos to 239.0.0.1, timeout is 2 seconds:


Reply to request 0 from 1.1.1.1, 120 ms

Reply to request 0 from 1.1.1.1, 120 ms

Reply to request 1 from 1.1.1.1, 120 ms

Reply to request 1 from 1.1.1.1, 180 ms

Reply to request 2 from 1.1.1.1, 120 ms

Reply to request 2 from 1.1.1.1, 120 ms

Reply to request 3 from 1.1.1.1, 92 ms

Reply to request 3 from 1.1.1.1, 152 ms

Reply to request 4 from 1.1.1.1, 120 ms

Reply to request 4 from 1.1.1.1, 120 ms

Reply to request 5 from 1.1.1.1, 120 ms

Reply to request 5 from 1.1.1.1, 232 ms


Now, see the difference on the host Mcast routing table:


R9#sh ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel

Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode


(*, 239.0.0.1), 00:05:08/stopped, RP 4.1.1.2, flags: SJPL

Incoming interface: FastEthernet0/0, RPF nbr 1.1.1.12

Outgoing interface list: Null


(2.2.2.2, 239.0.0.1), 00:03:30/00:02:41, flags: PLT

Incoming interface: FastEthernet0/0, RPF nbr 1.1.1.12

Outgoing interface list: Null


(4.1.1.2, 239.0.0.1), 00:03:30/00:02:41, flags: PLT

Incoming interface: FastEthernet0/0, RPF nbr 1.1.1.12

Outgoing interface list: Null


Harold Ritter Wed, 07/08/2009 - 10:33
User Badges:
  • Cisco Employee,

Edison,


I guess running a router as a host is not officially supported and the behavior might differ from one level of code to another. I tried with the latest 124 and it work just fine without enabling "ip multicast-routing" and yet the latest 12.4T requires it.


Regards

Edison Ortiz Wed, 07/08/2009 - 10:38
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Harold,


FWIW, I was running 12.2S



Harold Ritter Wed, 07/08/2009 - 10:45
User Badges:
  • Cisco Employee,

Edison,


I guess the bottom line is that having "ip multicast-routing" will always work, whereas not having it will sometimes not work. So it is probably better configuring it when the router is used to simulate a host.


Regards

Edison Ortiz Wed, 07/08/2009 - 11:22
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Yup, that's why I said one of those oddities with Mcast host and believe me I've discussed this with Reed on several occasions :)


Harold Ritter Wed, 07/08/2009 - 11:36
User Badges:
  • Cisco Employee,

Thanks Edison. Reed is definitely the man when it comes to multicast ;-)

lrm001c474 Tue, 07/07/2009 - 11:42
User Badges:

Multicast-routing needs to be enabled even if R9 just wants to join the group?


Thanks.

Harold Ritter Tue, 07/07/2009 - 11:50
User Badges:
  • Cisco Employee,

No. "ip igmp join-group" should be just fine.


Regards

Edison Ortiz Tue, 07/07/2009 - 12:36
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Unfortunately, when having a router acting as a Mcast host - that's the case.


__


Edison.

Harold Ritter Tue, 07/07/2009 - 11:31
User Badges:
  • Cisco Employee,

Robert,


PIM needs to be enable on R8 interface facing R9 (F1/0).


Regards

Mohamed Sobair Tue, 07/07/2009 - 12:13
User Badges:
  • Gold, 750 points or more


Hi Harold, Edison, ALL,


My point is that IGMP has to be enabled as well as Pim inorder for the information gets to all routers part of that group.


You either enable pim or create stub multicast routing.


Sorry its not my day, the USA and the whole world has lost a legend THE King Of POP (Michael Jackson). God Mercy On his Soul.


Mohamed

Actions

This Discussion