Terminate PPPoE on 2821 Router

Unanswered Question
Jul 7th, 2009
User Badges:

Hi all, I have Cisco 2821 with the following IOS: Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(25), RELEASE SOFTWARE (fc2)


I need to be able to terminate pppoe on this cisco. I wanted to use bba-group settings, but there are no commands for this on this IOS. There were vpdn settings, so I tried those, using any since pppoe is not an optional protocol for vpdn on this IOS. However, when trying to do this, I get the following error: PPPoE create bba subblock failed. Is this because the vpdn protocol is missing pppoe as an option? Do I need a different IOS? Any help is much appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Lucien Avramov Tue, 07/07/2009 - 12:11
User Badges:
  • Red, 2250 points or more

Do you have in mind to connect the 2800 to an ISP provider over for example DSL ?

You can use a dialer interface with PPP settings and then convert the cable modem or dsl modem into a bridge.


dj_oberry Tue, 07/07/2009 - 12:23
User Badges:

no in this case I would have dsl/pppoe users terminating on my cisco via a gigabitethernet interface.


so user pc-> modem -> through lines to cisco 2821, which would forward the radius/pppoe requests to radius server. I need the cisco to terminate the pppoe, not act as clients.


I know the 7200 series can do this, but I need to make this work with the 2821 if possible as the site this is located at is small and a 7200 is unfeasible there.

Lucien Avramov Tue, 07/07/2009 - 12:24
User Badges:
  • Red, 2250 points or more

Do you have a config on your 7200 ? I can check and see if the functions do exist on the 2800.

dj_oberry Tue, 07/07/2009 - 12:33
User Badges:

well the thing is the 7200 uses bba-group where the 2821 doesnt have that option, but has the older vdpn option. So its already different.


(No bba-group option in any level of config for 2821 as far as I can tell)


So I tried to use the following:


vpdn enable

!

vpdn-group 1

! Default L2TP VPDN group

! Default PPTP VPDN group

accept-dialin

protocol any

virtual-template 1



I'd use protocol pppoe there but the IOS wont take that, so I tried using any for protocol. When I go to enable the pppoe on the gigabit interface, I get:


#pppoe enable group global

PPPoE create bba subblock failed




Lucien Avramov Tue, 07/07/2009 - 13:39
User Badges:
  • Red, 2250 points or more

That should be fine, are you using a latest advanced enterprise image ?


I see some issues with using dot1q on the 2800 with pppoe. Else it should be ok.


Did you get a chance to check the feature navigator ?

www.cisco.com/go/fn


dj_oberry Tue, 07/07/2009 - 18:09
User Badges:

I have 12.4(25) code on the unit, IP Base according to the sho ver. Is this the issue? I need a version of code that is advanced enterprise?


(C2800NM-IPBASE-M), Version 12.4(25) is what I have.

Lucien Avramov Tue, 07/07/2009 - 20:43
User Badges:
  • Red, 2250 points or more

If i understand correctly you want to use L2TP Forwarding of PPPoE tag information ?


L2TP forwarding is only supported on :

1805

1861

7200

7300

SR520

UC520

VGD-1T3


dj_oberry Wed, 07/08/2009 - 04:12
User Badges:

No. Think of me using the router as a NAS device. You are a DSL/Wireless user. You use pppoe in your modem to connect to the internet. That pppoe information comes to my cisco. My cisco goes through the radius process (forwards the login request to radius server)and assigns an ip address from a ip pool setup on the cisco if the radius login info is correct. In this way, it would be acting more like a Redback/Portmaster than a pure router. It will do routing though as well. But that part works. I just need to get the NAS/termination of pppoe to work.

dj_oberry Wed, 07/08/2009 - 06:33
User Badges:

Thanks for the help. I was able to find the issue. I need an advanced ip services feature-set image. I will work on getting one.

Actions

This Discussion