DTMF between IOS gateway, Callmanager and Trixbox

Unanswered Question
Jul 8th, 2009
User Badges:

Hi guys,


I am trying to setup a Trixbox conference. This is working OK but when call from PSTN then the DTMF digits are not recognized. If I call from a SCCP phone which is registered to our callmanager it is working without a problem.


This is my setup:

Phone on PSTN <POTS>3825 12.4(15)T9<dail-peerH323>Callmanager 6.1<SIP>Trixbox<SIP>Sip-phone


I am using G711ulaw as codec, I am not using the media termation point checkbox in CUCM. The trunk is not working anymore if I do that.


All DTMF settings are set to RFC2833 (on extensions, sip trunk on Trixbox and callmanager).The dial peer is configured:

dial-peer voice 1234 voip

preference 1

destination-pattern XXXXXXXXXX

progress_ind setup enable 3

voice-class codec 1

session target ipv4:(ip addr CUCM)

dtmf-relay rtp-nte

fax rate disable

no vad



Does anyone has an idea what the problem is?


Thanks in advance,


Jeroen


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Wed, 07/08/2009 - 11:46
User Badges:
  • Red, 2250 points or more

Hi Jeroen,


You would want to check the payload type value in the SDP of the 200 OK/INVITE from the Trixbox. IOS will use 101 by default, but you can change this with a dial peer command "rtp payloard rtp-nte ".



-nick

jmaat Fri, 07/10/2009 - 05:20
User Badges:

Hi Nick,


Thanks a lot for your answer.


The H323 protocol is used between the router and Callmanager. A SIP trunk is used between Trixbox and Callmanager. Isn't it something between CUCM and Trixbox then?


I am not sure what is used on the Trixbox. I need to make sniffer trace but I need to go onsite. I will let you know the outcome.


Thanks!


Jeroen

dvdhouwen Fri, 07/10/2009 - 07:55
User Badges:

On the trixbox side we see this information for the call:


edcapptrixs51*CLI>

* SIP Call1*CLI>

Curr. trans. direction: Incoming

Call-ID: [email protected]

Owner channel ID:

Our Codec Capability: 12

Non-Codec Capability (DTMF): 1

Their Codec Capability: 0

Joint Codec Capability: 0

Format: 0x0 (nothing)

MaxCallBR: 0 kbps

Theoretical Address: 10.71.1.84:5060

Received Address: 10.71.1.84:5060

SIP Transfer mode: open

NAT Support: RFC3581

Audio IP: 10.200.4.201 (local)

Our Tag: as3a26fdb6

Their Tag: as1280e73a

SIP User agent: Asterisk PBX

Need Destroy: 0

Last Message: Rx: OPTIONS

Promiscuous Redir: No

Route: N/A

DTMF Mode: rfc2833

SIP Options: (none)


edcapptrixs51*CLI>

* SIP Call

Curr. trans. direction: Incoming

Call-ID: [email protected]

Owner channel ID: SIP/10.206.84.10-08221d80

Our Codec Capability: 4

Non-Codec Capability (DTMF): 1

Their Codec Capability: 4

Joint Codec Capability: 4

Format: 0x4 (ulaw)

MaxCallBR: 384 kbps

Theoretical Address: 10.206.84.10:5060

Received Address: 10.206.84.10:5060

SIP Transfer mode: open

NAT Support: RFC3581

Audio IP: 10.200.4.201 (local)

Our Tag: as3c0afcbc

Their Tag: 054c0f9d-8b3b-4e2d-912b-36db99c8b4d7-63064715

SIP User agent: Cisco-CUCM6.1

Peername: to-CCM-SIP-EU

Original uri: sip:[email protected]:5060

Caller-ID: 00104383161

Need Destroy: 0

Last Message: Rx: ACK

Promiscuous Redir: No

Route: sip:[email protected]:5060

DTMF Mode: rfc2833

SIP Options: replaces replace timer


-----------

The dial-peer on the router is configured with these settings:


dial-peer voice 4029 voip

preference 1

destination-pattern xxxxx4029

progress_ind setup enable 3

voice-class h323 1

session target ipv4:10.x00.1x.251

dtmf-relay rtp-nte h245-signal

fax rate disable

no vad


-------------


In this Troxbox forum thread is described that the expected payload type is 101 or 121

http://www.trixbox.org/forums/trixbox-forums/sip-and-iax-trunks-and-providers/rtp-payload-96-need-modify-source-code-and-re


How can this type be forced on the dial-peer?


Danny

Nicholas Matthews Mon, 07/13/2009 - 09:37
User Badges:
  • Red, 2250 points or more

This output doesn't clarify whether or not it is 101 or 121 (or something else).


We will do 101 by default.


You can try this dial peer command:


rtp payload nte 121




hth,

nick

jmaat Mon, 07/13/2009 - 23:33
User Badges:

HI Nick,


Thanks for your answer This is the output of this command, it is still not working.

rotnar01(config-dial-peer)#rtp payload-type nte 121

ERROR: value 121 in use!

rotnar01(config-dial-peer)#rtp payload-type nte 101

rotnar01(config-dial-peer)#


Here are the properties of the dial-peer:


rotnar01#show dial-peer voice XXXX

VoiceOverIpPeerXXXX

peer type = voice, system default peer = FALSE, information type = voice,

description = `',

tag = XXXX, destination-pattern = `XXXXXXXXX',

voice reg type = 0, corresponding tag = 0,

allow watch = FALSE

answer-address = `', preference=1,

CLID Restriction = None

CLID Network Number = `'

CLID Second Number sent

CLID Override RDNIS = disabled,

source carrier-id = `', target carrier-id = `',

source trunk-group-label = `', target trunk-group-label = `',

numbering Type = `unknown'

group = XXXX, Admin state is up, Operation state is up,

incoming called-number = `', connections/maximum = 0/unlimited,

DTMF Relay = enabled,

modem transport = system,

URI classes:

Incoming (Called) =

Incoming (Calling) =

Destination =

huntstop = disabled,

in bound application associated: 'DEFAULT'

out bound application associated: ''

dnis-map =

permission :both

incoming COR list:maximum capability

outgoing COR list:minimum requirement

Translation profile (Incoming):

Translation profile (Outgoing):

incoming call blocking:

translation-profile = `'

disconnect-cause = `no-service'

advertise 0x40 capacity_update_timer 25 addrFamily 4 oldAddrFamily 4

type = voip, session-target = `ipv4:XX.XXX.XX.XX',

technology prefix:

settle-call = disabled

ip media DSCP = ef, ip signaling DSCP = af31,

ip video rsvp-none DSCP = af41,ip video rsvp-pass DSCP = af41

ip video rsvp-fail DSCP = af41,

UDP checksum = disabled,

session-protocol = cisco, session-transport = system,

req-qos = best-effort, acc-qos = best-effort,

req-qos video = best-effort, acc-qos video = best-effort,

req-qos audio def bandwidth = 64, req-qos audio max bandwidth = 0,

req-qos video def bandwidth = 384, req-qos video max bandwidth = 0,

dtmf-relay = rtp-nte digit-drop,

RTP dynamic payload type values: NTE = 101

Cisco: NSE=100, fax=96, fax-ack=97, dtmf=121, fax-relay=122

CAS=123, TTY=119, ClearChan=125, PCM switch over u-law=0,

A-law=8, GSMAMR-NB=117 iLBC=116

h263+=118, h264=119

G726r16 using static payload

G726r24 using static payload

RTP comfort noise payload type = 19

fax rate = disable, payload size = 20 bytes

fax protocol = system

fax-relay ecm enable

Fax Relay SG3-to-G3 Enabled (by system configuration)

fax NSF = 0xAD0051 (default)

voice-class codec = 1

codec = g729r8, payload size = 20 bytes,

video codec = None

voice class codec = 1

text relay = disabled

Media Setting = flow-through (global)

Expect factor = 10, Icpif = 20,

Playout Mode is set to adaptive,

Initial 60 ms, Max 250 ms

Playout-delay Minimum mode is set to default, value 40 ms

Fax nominal 300 ms

Max Redirects = 1, signaling-type = cas,

VAD = disabled, Poor QOV Trap = disabled,

Source Interface = NONE

voice class sip url = system,

voice class sip rel1xx = system,

tvoice class sip outbound-proxy = system,

voice class sip asserted-id = system,


Thanks again,


Jeroen

Nicholas Matthews Tue, 07/14/2009 - 04:44
User Badges:
  • Red, 2250 points or more

I see that you have rtp-nte digit drop configure. Please remove the digit drop as this is not a scenario where it is correct.


-nick

jmaat Thu, 07/16/2009 - 01:35
User Badges:

Hi Nick,


We already tried that. We tried all options. It's back now to dtmf-relay rtp-nte but still not working.


Thanks,

Actions

This Discussion