WRP400 Voice no audio

Unanswered Question
Jul 8th, 2009

Hi,

We have following situation. Asterisk as PBX and 2 SPA942 and 1 PAP2 with 2 analog phones connected. All is working prefectly until we added WRP400 to replace PAP2. Analog phones connected to WRP400 are registered on Asterisk. They are ringing on call but no audio on both sides. SPA 942 connected to WRP400 haven't any problem and PAP2 connected to the WRP400 with both analog phones is working perfectly but only voice piece of WRP400 isn't working.

We have checked configuration of voice piece of WRP400 many time and it seems all properly configured. An port forwarding or firewall issue couldn't be because SPA942 and PAP2 connected to the WRP400 are working fine. Firmware upgrade doesn't solved our problem.

Have you any idea what could be the problem? Any help would be appreciated.

P.S. Sorry for my bad english because isn't my mother language.

Best regards,

Pera

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Mon, 07/13/2009 - 07:29

Dear Sir;

I would need to see the traces from the WRP400 to understand if it is a defective unit.

Regards;
Alberto

perapapak Sun, 07/19/2009 - 00:57

Hello Alberto,

Sorry but I'm new on this. What I need to do?

Best regards

Patrick Born Tue, 07/21/2009 - 15:48

Hi perapapak,

Some questions:

  1. What version of firmware is the WRP400 running?
  2. Do you hear audio when analog1 calls analog2, or when analog2 calls analog1?
  3. Do you hear audio between analog1/2 and SPA942?
  4. Do you hear audio between SPA942-1 and SPA942-2?

Some suggestions:

  1. Run Asterisk console in verbose mode and observe what is reported in Asterisk's console when using FXS1/2 with no audio, may provide clues:
    $ sudo /etc/init.d/asterisk stop
    $ sudo /usr/sbin/asterisk -cgvvv
  2. Enable debug on the WRP400, the syslog output may provide clues when using FXS1/2 with no audio

For further troubleshooting, please provide:

  • WRP400 voice config
  • /etc/asterisk/sip.conf
  • /etc/asterisk/extensions.conf

Regards,

Patrick

----------

perapapak Thu, 07/23/2009 - 10:26

> Some questions:

> What version of firmware is the WRP400 running?

It was delivered with 1.00.04 and now is 2.00.05 running. Both versions have the same problem.

> Do you hear audio when analog1 calls analog2, or when analog2 calls analog1?

No if analog1/2 connected on voice part of WRP400 and yes if analog1/2 connected to the PAP2 attached on WRP400.

> Do you hear audio between analog1/2 and SPA942?

No if analog1/2 connected on voice part of WRP400 and yes if analog1/2 connected to the PAP2 attached on WRP400.

> Do you hear audio between SPA942-1 and SPA942-2?

Yes.

> Some suggestions:

> Run Asterisk console in verbose mode and observe what is reported in Asterisk's console when using FXS1/2 with no audio, may provide         >  clues:
> $ sudo /etc/init.d/asterisk stop
> $ sudo /usr/sbin/asterisk -cgvvv

We did it allready but no clues.

> Enable debug on the WRP400, the syslog output may provide clues when using FXS1/2 with no audio

Enabled. See log attached on my previous post. Tried to call analog <=> SPA-942 and no audio both times.

> For further troubleshooting, please provide:
> * WRP400 voice config
> * /etc/asterisk/sip.conf
> * /etc/asterisk/extensions.conf

I can provide but I'm not sure how can this help. Again all VoIP devices in network are working properly except voice part of WRP400. 2 SPA-942 phones (one SPA-942 connected to the switch on WRP400), 2 analog devices connected to the PAP2 (connected to the switch on WRP400), and many software phones such Eyebeam and Bria and no one have any problem except voice part of WRP400.

How can I test device to check if voice part is defect?

Thanks in advance.

Patrick Born Thu, 07/23/2009 - 16:00

Please load 1.01.00 on the WRP400 and test. The 2.x train of firmware is for 3G, so it's best to use 1.x if  you are not implementing 3G.

As I mentioned before, I don't see anything useful in the debug that you previously supplied. Perhaps a Wireshark trace from the LAN would reveal something?

I'm wanting the config files to try figure out what is wrong. My hunch is that there's a conflict in the configuration between the WRP400 and Asterisk. Both provide call-control, so the opportunities for config errors are great. :-)

Can you help me understand why you want to use the WRP400's call control when the rest of your network is using Asterisk? I'm thinking that I'm not fully understanding the network and implementation.

Please help validate my understanding:

  • As I understand it, you have Asterisk providing call control and acting as SIP proxy for all devices.
  • You used to have a PAP2 because you wanted 2 FXS ports for analog phones for the Asterisk environment
  • You have now removed the PAP2 and installed the WRP400 which provides:
    • Wireless access point
    • 4-port switch
    • 2-fxs ports
    • Call control [why do you want this if you have Asterisk?]

Regards,

Patrick

----------

perapapak Fri, 07/24/2009 - 12:02

Hello Patrick,

Sorry but I dont' understand which Call control as replacement for Asterisk on WRP400 you mean. As I know WRP400 is WLAN Access point with 2-fxs ports and voice part of device is similar with PAP2. In voice part both lines are configured to access Asterisk server like on PAP2. I didn't see anything other like "Call control" or I missed something. I replaced Zyxel WLAN Access Point and PAP2 with only one device and I use Asterisk as before. I didn' ^t see anywhre taht voice part of WRP400 could replace Asterisk or an VoIP Provider.

Please clarify me if I'm wrong.

Regard,

Pera

Patrick Born Fri, 07/24/2009 - 14:55

Hi Pera,

My mistake, not sure what I was thinking and forgot that it's just an ATA.

I'll edit my previous post so it will not confuse others.

Can you please share the voice config of the WRP400 for analysis?

Regards,

Patrick

-----------

perapapak Tue, 08/04/2009 - 00:15

Hi Patrick,

Sorry for delay but I'm in vacation and no posibility to check my mails every day. After return I'll share my configuration. Do you need all of voice part or only for analog lines?

Regards,

Pera

Patrick Born Thu, 09/10/2009 - 15:43

Hi Pera,

I hope that you had a great holiday.

In order to further troubleshoot this, I need the following:

Regards,

Patrick

----------

perapapak Wed, 09/23/2009 - 06:29

Hi Patrick,

Sorry for delay but I have had to much work in my job.

> In order to further troubleshoot this, I need the following:

I added pictures of PAP-2 and WRP400 voice config, both asterisk conf files and wireshark trace captured at asterisk machine. Notice: our asterisk is managed vith FreePBX and most config files are configured from FreePBX.

I called first via PAP-2 and then called with phone attached to the wrp400 directly.

If you need another files or pictures tell me.

Regards,

Pera

Attachment: 
perapapak Tue, 09/29/2009 - 02:34

Hi Patrick,

I's no difference between firmware 1.x and 2.x. We tried both and the problem is same. And we need 3G as backup connections.

Herre are configs of PAP-2 and SPA-642.

Regards,

Pera

Patrick Born Tue, 09/29/2009 - 14:40

Hi Pera,

Thanks for providing the additional information. I have shared the information with Engineering in the hopes that they can help figure this out.

Regards,

Patrick

-----------

perapapak Wed, 09/30/2009 - 06:21

Hi Patrick,

1. Do you need WRP400 voice configuration with connected phonet to the WRP400 or just so as it because analog phones not use WRP400 but PAP-2.

2. Not a clue. We have 2 providers:

www.sipcall.ch

Betamax with many clones such Voipbuster, Poivy etc.

But the problem is between local phones too. Do you thins is voice part of WRP400 probably fault?

Regards,

Pera

Patrick Born Wed, 09/30/2009 - 08:22

Hi Pera,

I am under the impression that you have 2 analog phones connected to the WRP400 that ring, but when answered, do not produce audio. From the https://supportforums.cisco.com/message/3094931#3094931 description, the same analog phones work without problem in the same environment when connected to your PAP-2 instead of the WRP400.

Can you please restate the problem that we're trying to resolve? :-)

Regards,

Patrick

----------

perapapak Wed, 09/30/2009 - 09:30

> I am under the impression that you have 2 analog phones connected to the WRP400 that ring, but when answered, do not produce audio. From the                  > https://supportforums.cisco.com/message/3094931#3094931 description, the same analog phones work without problem in the same environment when           > connected to your PAP-2 instead of the WRP400.

Exactly. And our PAP-2 is connected to the WRP400. And no audio is fi I call or be called from or analog phones.

Regards,

Pera

Patrick Born Wed, 09/30/2009 - 14:55

Pera,

Is the analog phone connected to PHONE 1 or PHONE 2 of the SPA400?

Regards,

Patrick

----------

perapapak Thu, 10/01/2009 - 00:32

I have 2 analog phones. One analog phone connected to PHONE 1 and other analog phone connected to PHONE 2 of the WRP400 (not SPA400).

Last try was with only one analog phone connected to PHONE 1 as I made phone configuration picture.

raisacomhb Thu, 10/01/2009 - 00:25

Hi,

I  haven't had a look on your configs yet, but maybe I'm hitting a point:

Just to be sure that the audio part of the WRP400 is not broken anyhow, is it possible for you to access the IVR by entering ' * * * * ' on any phoneport? The device will confirm every key in the IVR by repeating it phonetically. If that is working, you can assume your device being not broken (never say never :-)

BTW, I suggest adding an echo extension to your asterisk dial plan in extensions.conf, e.g.

exten => _01189876!,1,Echo()   ; use _0089876! in Europe


Try to dial that number and you should hear yourself. Do you?

Another issue: is your Asterisk connected to one of the LAN ports of the WRP400 and do you have STUN and NAT enabled on the phone lines? That will probably not work! I just roughly inspected the configs. STUN does not seem to be enabled. You are using FreePBX. Changing the configuration files manually there is hard work if you're not in it, well I'm not :-)

Best regards,

  Eik Rentzow

perapapak Thu, 10/01/2009 - 01:17

Echo test allready exsist on the Asterisk. Good idea. I'l try.

Asterisk isn't connected to the WRP400 but to the another switch in LAN and STUN isn't used anyway.

Patrick Born Thu, 10/22/2009 - 14:37

Hi Pera,

Apologies for the delayed response, I've been on business travel.

One thing to keep in mind is that a PAP2 is not the same device as a WRP400. The WRP400 is much more complex....

Looking at your config, I see that you have changed the SIP and RTP ports. A typical problem when RTP is restricted, in any way, is one-way audio.

Please consider factory-defaulting the WRP400 and configuring the bare minimum to get it working, as in SIP proxy and user credentials only.

Once you have verified that 2-way audio works, change the settings on the WRP400 in small increments, making sure that 2-way audio continues to function.

Consider using a combination of WRP400 syslog, Asterisk console messages, and Wireshark traces so you can immediately determine where the RTP stream is going wrong.

Best of luck,

Patrick

-----------

perapapak Fri, 10/23/2009 - 01:08

> Looking at your config, I see that you have changed the SIP and RTP ports. A typical problem when RTP is restricted, in any way, is one- > way audio.

I have NO AUDIO and not one-way audio. The ports are the same such in PAP2 and RTP ports from Asterisk config. I can this problem with one-way audio and RTP ports exactly and I tried allready without success.
 
> Please consider factory-defaulting the WRP400 and configuring the bare minimum to get it working, as in SIP proxy and user credentials    > only.
>
> Once you have verified that 2-way audio works, change the settings on the WRP400 in small increments, making sure that 2-way audio       > continues to function.

> Consider using a combination of WRP400 syslog, Asterisk console messages, and Wireshark traces so you can immediately determine where the > RTP stream is going wrong.

I see. You have not a clue. I configured many VOIP devices and have had no one problem only with this WRP400. And if I have so much knowledge to work with WRP400 syslog, Asterisk console messages, and Wireshark traces as you say then my question here was unnecessary because you mean I can solve it himself. For what I sent so much informations? If you see anything there to help me then tell me please.

I can give a try with factory-defaulting again but what if I have no audio furthermore? WRP400 in trash can? Probably is the best solution instead to waste time and no more to buy Linksys/Cisco products.

Pera

perapapak Tue, 10/27/2009 - 07:48

1. factory reset of WRP400

2. Line 1 only user credentials and proxy.

3. Attached analog phone on line 1 of WRP400

Trying to call another extensions form phone on line 1. I hear after dialing only busy tone. No activity in Asterisk log.

Trying from another extentions to call phone on line 1. The phone is ringing but after answering no audio (on both sides).

So your solution is nothing worth. And if WRP400 isn't defect it's very bad product.

Patrick Born Wed, 10/28/2009 - 08:24

Hi Pera,

I registered a factory defaulted WRP400 [running 1.01.00] Line 1 to my Asterisk server and can make calls with audio between an IP phone on the LAN and an analog phone attached to PHONE 1 of the WRP400.

I completed this task in about 5 minutes, without any trouble.

I did the following:

1. Edited Asterisk server:

a. sip.conf

b. extensions.conf

c. *CLI> sip reload

d. *CLI> dialplan reload

2. Configured WAN interface of WRP400
     [it's a router, if this interface is not properly configured, the voice lines will not properly register with the Asterisk server]

a. Configured LAN inteface to static

b. WRP400 Line 1>

i. Proxy & Registration > Proxy > 192.168.2.245:5060 [IP address of asterisk server]

ii. Display Name> wrp400line1

iii. user ID: 401

iv. Password: 401secret

3. Submit all changes

4. I can now make calls with 2-way audio.

With VoIP, two protocols are used, SIP and RTP. SIP controls the session, but RTP carries the audio. The called phone ringing means that SIP is getting through. The lack of audio means that RTP is not getting through. This is why I encourage you to not change any SIP or RTP ports on the WRP400 until you have a basic configuration working.

As I mentioned in an earlier post, the WRP400 is not the same as a PAP2 device. It includes router functionality which increases the complexity of the solution as compared to using a PAP2.

Regards,

Patrick

-----------

perapapak Thu, 11/12/2009 - 07:41

> 2. Configured WAN interface of WRP400
>     [it's a router, if this interface is not properly configured, the voice lines will not properly register with the Asterisk                                                          > server] 

What you mean exactly with "[it's a router, if this interface is not properly configured, the voice lines will not properly register with the Asterisk server] "?

WRP400 isn't directly attached to the cable modem. It's Linksys BEFSX41 connected to the cable modem and act as router and WRP400 is connected via LAN to the Linksys BEFSX41. As I understand Admin Manual from here: http://www.cisco.com/en/US/docs/voice_ip_comm/csbpvga/wrp400/administration/guide/WRP400_AG_OL-19688.pdf it schouldn't be any problem in this configuration or am I wrong?

I attached my basic setup of WRP400.

Regards,

Pera

Attachment: 
raisacomhb Thu, 11/12/2009 - 09:53

Maybe the problem is the complete IP setting.

You make the device requesting DHCP on the (blue) Internet port, that is not connected, but also specify DNS servers that are outside of your LAN. This messes things up with unexpecting behaviour I guess. The other SPAs e.g. don't even reply to **** if they had this setting.

So, change the external mode to Static IP and enter an unused local network address (e.g. 192.168.199.12). Next enter your routers IP address (internal) in one of the DNS fields or add an extra route entry (that's advanced configuration). It may work now already.

IMHO it is definitely better to connect the WRP400 to the blue internet port instead to the LAN ports! What else are you using your WRP400 for? Just as ATA and network switch? The device is not intended for this use, so don't bother it for being complicated in your case :-)

Best luck!

Eik

perapapak Thu, 11/12/2009 - 12:45

Hi,

I just tired but it seems WRP400 don't accept this configuration or I did something wrong. See attached files.

I use WRP as WLAN and 3G access point ans ATA. One device instead two (wlan access point + PAP2).

Regards,

Pera

Attachment: 
raisacomhb Fri, 11/13/2009 - 05:13

Yes, the WAN network and the LAN network MUST NOT be the same. I.e. if the LAN network shall be 192.168.1.0 (IPs range from 192.168.1.1 to 192.168.1.254) then WAN network must be different, for example 192.168.2.0. That's why I suggest this 'strange' IP address in my last message.

Try it again with this information and don't forget to set the DNS to your actual router.

By the way, the site configuration you are trying to set up really is not trivial and even sometimes IT profs (the 'light' ones :-) fail in doing so!

Best regards,

  Eik

Actions

This Discussion