×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

7945 Displaying Wrong Time

Unanswered Question
Jul 8th, 2009
User Badges:

Customer's UC500 system is set for US Central time, using NTP to update.  Times are correct everywhere except on one 7945 phone, which displays Pacific time.  How can I fix this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Wed, 07/08/2009 - 09:23
User Badges:
  • Gold, 750 points or more

Can you post your config and verify the firmware on the phone?

aapexisinc Wed, 07/08/2009 - 10:43
User Badges:

The phone reports:  Load File SCCP45-8-3-5S

                             Apps Load ID jar45sccp.8-3-4.16.sbn

                             JVM Load ID cvm45sccp.8-3-4-16.sbn

                             OS Load ID cnu45.8-3-4-16.sbn

                             Boot Load ID tnp45.8-3-1-21a.bin

                             DSP Load ID dsp45.8-3-4-16.bin


Config attached.

Attachment: 
Steven Smith Wed, 07/08/2009 - 11:05
User Badges:
  • Gold, 750 points or more

can you do this...


config t

telephony-service


no create cnf-files

create cnf-files


Reboot the phone, and see if that works

aapexisinc Wed, 07/08/2009 - 12:08
User Badges:

No, that didn't work.  Still displaying Pacific time.

jorgediaz77 Wed, 07/08/2009 - 17:02
User Badges:

I ran into a similar problem and it was a combination of problems. One was the phone loads were outdated, the other was the IOS, we ran one of the early releases of the IOS to get the one button LiveRecord feature to work. Apparently there was a conflict with this and the CCA. I ended up rolling back to the latest working IOS, upgrading to CCA 2.0.1 and uploading the latest phone builds and things are working now.

aapexisinc Mon, 07/13/2009 - 17:13
User Badges:

I've updated the phone loads for the 7945 to 8-4-2, but the phone will not update its firmware when rebooted; it remains at 8-3-5.  I updated the 7945-7965 phone load files, the tftp-server commands and the load command via CLI.  What did I miss to get the phone to update its firmware?

aapexisinc Tue, 07/14/2009 - 12:21
User Badges:

Found the problem with the firmware update (and probably the original time problem).  The phone is connected through a switch (not a Cisco switch), causing it to be assigned a 192.168.0.x ip address, rather than a 10.1.1.x address.  The phone registers and works perfectly, but the update doesn't happen.  When connected to the UC520 directly, however, it gets a 10.1.1.x address and updates properly.   When reconnected through the switch, it now has the correct time and firmware, even though it again has a 192.168.0.x address.


So, is there a way to have the phone automatically assigned a 10.1.1.x address, even though it's not directly connected?

Steven Smith Tue, 07/14/2009 - 12:27
User Badges:
  • Gold, 750 points or more

If the switch can support trunks and that switch is connected to the expansion port, you could do it.  I would have thought TFTP would still have worked here though.  You might want to look into why TFTP wasn't working.

aapexisinc Tue, 07/14/2009 - 12:36
User Badges:

I'm not sure what the switch can support; I didn't install it.  I believe it is connected to the expansion port, though.  Where would I start looking to try to find out why tftp wasn;t working?

Steven Smith Tue, 07/14/2009 - 12:44
User Badges:
  • Gold, 750 points or more

term mon

debug tftp events

debug tftp packets


See what the output is when you reboot the phone.  Unfortunately, you need the phone to be trying to upgrade.  You could also see if there are any ACL's on the vlan or bvi interfaces.

Marcos Hernandez Tue, 07/14/2009 - 12:49
User Badges:
  • Blue, 1500 points or more

Is 192.168.0.X your UC500 Data VLAN? Assuming it's not, then the phone is getting DHCP from somewhere else. This comment is not realted to your problem, but just make sure your data DHCP server on the UC500 is disabled if you are using another one.


Marcos

aapexisinc Tue, 07/14/2009 - 15:38
User Badges:

The BVI interfaces each have an ACL which excludes the other; i.e., BVI1 (data) ACL 102 has a "deny ip 10.1.1.0 0.0.0.255 any" and BVI100 (phones) ACL 103 has a "deny ip 192.168.0.0 0.0.0.255 any".  Can the BVI100 ACL safely have the deny ip 192.168.0.0 removed?

Actions

This Discussion