Missing Phoneloads

Unanswered Question
Jul 8th, 2009
User Badges:

Somewhere over the course of upgrading a UC500 to 7.1.1ea the phoneloads and locale files for many of the phones (e.g., 7970, 7931) went missing.  Where can I find them and how do I restore them?  Following the instructions after the upgrade to update to the language files for the current regiion did not work, as the referenced directory is empty.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven Smith Wed, 07/08/2009 - 09:39
User Badges:
  • Gold, 750 points or more

In the 7.1.1 software pack, you should have a tar file called CME-Phone-Loads-7.1.1.tar.


If you open that, you will see the loads sorted into directories by phone type.  Copy of all the files in the directories to the flash on your UC.  You should also keep the files in the same directory structure that exists in the tar file today. (flash:/phones/7931/ etc)


Then verify that the TFTP commands are setup with these new files correctly.


Let me know if you have any problems.

aapexisinc Wed, 07/08/2009 - 10:54
User Badges:

Dumb question: how do I copy those files to the flash?

Steven Smith Wed, 07/08/2009 - 11:26
User Badges:
  • Gold, 750 points or more

I would get a TFTP client, like pumpkin TFTP.


http://kin.klever.net/pumpkin/binaries



Place your computer behind the UC


From the command prompt on the UC, you will need to use the copy tftp to flash commands.


UC520#copy tftp flash:
Address or name of remote host []? 192.168.10.18
Source filename []? test.png
Destination filename [test.png]?
Accessing tftp://192.168.10.18/test.png...
Loading test.png from 192.168.10.18 (via Vlan1): !
[OK - 18054 bytes]


18054 bytes copied in 0.692 secs (26090 bytes/sec)
UC520#


You can also include names and directories in this as well


UC520#
UC520#copy tftp://192.168.10.18/phones/7915/B015-1-0-3.SBN flash://phones/7915/
Destination filename [/phones/7915/B015-1-0-3.SBN]?
Accessing tftp://192.168.10.18/phones/7915/B015-1-0-3.SBN...
Loading phones/7915/B015-1-0-3.SBN from 192.168.10.18 (via Vlan1): !
[OK - 146463 bytes]


146463 bytes copied in 1.480 secs (98961 bytes/sec)
UC520#



If the directory isn't there, you might need to create it.


UC520#cd phones
UC520#pwd
flash:/phones/
UC520#mkdir 7915


That created flash://phones/7915/


Let me know if you need any more help.

Marcos Hernandez Thu, 07/09/2009 - 10:22
User Badges:
  • Blue, 1500 points or more

You can also drag and drop the files from the CCA topology view. Make sure no other TFTP/FTP servers are running on your PC when trying this method.


Thanks,


Marcos

aapexisinc Thu, 07/09/2009 - 11:22
User Badges:

Marcos,


I tried to drag and drop from Windows Explorer, but it doesn't allow it.  Am I missing something?  I'm running CCA 2.0.1.

aapexisinc Thu, 07/09/2009 - 12:39
User Badges:

That worked, although I also had to update the tftp-server configuration commands to reflect the new files.  One last issue, when the phone restarts it reports two errors: 1) DNS Unknown Host; and 2) Error Updating Locale.  Where do I look to fix these?

Marcos Hernandez Sun, 07/12/2009 - 08:28
User Badges:
  • Blue, 1500 points or more

Do these errors cause any other issues? Are you trying to localize the system?


Thanks,


Marcos

aapexisinc Sun, 07/12/2009 - 19:13
User Badges:

They don't appear to cause any issues, but, then, the phone still worked even when it was entirely missing the load files (it just threw off a couple of errors which you would miss if you weren't looking).  I just don't like unexplained error messages.  The phone is using the default US English.

Steven Smith Mon, 07/13/2009 - 11:54
User Badges:
  • Gold, 750 points or more

Has the phone ever been a locale other than english?


When do you see the DNS unknown host error?

aapexisinc Mon, 07/13/2009 - 12:09
User Badges:

The phone has never been in a different locale.  The messages appear when the phone registers (or is reset).

Actions

This Discussion