UC 7.0 : Error when switching version

Unanswered Question
Jul 8th, 2009
User Badges:

Hi, I'm currently having troubles trying to switch my UC version from 7.0.2.20000-5 to 7.1.2.20000-2.


I'm getting the following error message: Sync after switch version failed.


UCM is already running on 7.1.20000-2


Any insight would be greatly appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Wed, 07/08/2009 - 11:16
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

When you log into ccmadmin what version does it show?

PUB? SUB?


java

stephanebelzile Thu, 07/09/2009 - 04:19
User Badges:

Hi,


My callmanagers are at the following release:


Publisher is at System version: 7.1.2.20000-2


Subscriber is also at System version: 7.1.2.20000-2

htluo Thu, 07/09/2009 - 08:38
User Badges:
  • Red, 2250 points or more

Try "utils system switch-version nodatasync".


See if it works? If not, reboot the system and re-attempt the switch.


Michael

http://htluo.blogspot.com

stephanebelzile Thu, 07/09/2009 - 09:17
User Badges:

Hi,


I did try what you suggested, still no luck. Restart didn't help either.

Rob Huffman Fri, 07/10/2009 - 05:50
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Stephane,


Just to clarify here, are you referring to Unity Connection 7 for the problems with the version switch? If so, I would open a TAC Case as there are a few Bugs that may be causing this problem.


Cheers!

Rob

Naren Patel Fri, 07/24/2009 - 23:09
User Badges:

Hello


I got the same problem and I have fixec it by :


1. restart Pub

2. restart sub

3. then on sub "utils system switch-version nodatasync" and it worked.

billybjo1 Tue, 07/28/2009 - 14:31
User Badges:

I'm getting similar problems on an upgrade from 6.x to 7.0(2). However there seems to be no keyword "nodatasync" if I do a ?. It will still let me type it but fails with the same errors as if the parameter doesn't exist. So I'm unable to switch back to 6. Anyone got any ideas how I can switch?

Naren Patel Tue, 07/28/2009 - 14:57
User Badges:

Hello,


Have a look at the message I posted earlier. I had the same error and I manage to upgrade it after I got that message.


Reboot both PUB and then SUB. execute the command with nosyncdata after the reboots and it worked for me.



billybjo1 Tue, 07/28/2009 - 15:00
User Badges:

This is only a single server system. Unfortunately the command [nodatasync] doesn't appear after the utils system switch-version. If I look at other 7.0(1) systems the command is there, but not on this 7.0(2).

So I'm stuck on how to switch back.

billybjo1 Tue, 07/28/2009 - 15:15
User Badges:

Incidently the exact version is 7.0.2.21900-10.

If anyone else has got this version can I ask you do a cli "utils system switch-version ?" and see if you see [nodatasync]. This is very wierd as it seems Cisco have missed the option off the command. And if you have the error at the head of this thread, there seems no way of switching back.

Brian Carlson Thu, 08/13/2009 - 16:12
User Badges:

Hi I had this same issue today where I received a "sync after switch failed" error. The problem turned out to be with DNS, make sure you are able to resolve the hostname of the server, not just it's fully-qualified-domain-name (FQDN).


For example if your server is named SERVER1, make sure SERVER1 resolves, and not just SERVER1.domain.com.


With my server, SERVER1.domain.com was resolving, but not SERVER1. Once I added an entry in DNS for SERVER1, I was able to switch versions without issue.



Terry Dever Fri, 11/09/2012 - 11:36
User Badges:

I got past this error.  I was upgrading Cisco Unity Connection (on UCS) from 8.6.2 --> 8.6.2su2.  I have a Pub & Sub.  I upgraded the Pub and THEN tried to do the "utils system switch-version".  According to this link (

http://www.cisco.com/en/US/docs/voice_ip_comm/connection/8x/upgrade/guide/8xcucrug006.html#wp1070971), the proper way to do it is to upgrade the Pub, let it reboot and totally 100% come up with all services etc (the way to make sure is just wait about 10 mins after it boots and try to https:///cuadmin for ex).  Then upgrade the Sub, let it 100% come up.  THEN you go to the Pub and do the "utils system switch-version", let it do its thing / reboot / whatever / let it 100% fully come up THEN do the same on the Sub.  More key notes from the link above to cut right to the chase:


10. Upgrade the Connection software on the publisher server. See the applicable section:

Caution Do not restart the publisher server and do not switch to the upgraded software during this task. Otherwise, the Connection cluster will not function correctly.

14. Upgrade the Connection software on the subscriber server. See the applicable section:

Caution Do not restart the subscriber server and do not switch to the upgraded software during this task. Otherwise, the Connection cluster will not function correctly.

15. Switch to the upgraded software on the publisher server.

16. On the publisher server wait for the services to start and then switch on the subscriber server.

Not following this process could cause the problem that you are experiencing

If you did not followed the process, the action plan is as follows:

1.       Switch version on the node which is running newer software version (to the old one)

2.       Reset Replication between the nodes using

a.      Utils dbreplication stop on SUB server

b.     Utils dbreplication stop on PUB server

c.      Utils dbreplication reset on PUB

3.       After dbreplication is working  (#utils dbreplication runtimestate should show status of (2), switch version on PUB, then switch version on SUB

If the following Action plan would fail from any reason it is most likely that SUB server will require rebuild

Abbas Hussain Sat, 04/05/2014 - 21:51
User Badges:

Hi terry- dever 

I followed your recommendation for the unity connection upgrade from 8.6 to 9.1.2. and it worked good.

 

Thanks for your Post.

 

Abbas

 

Actions

This Discussion