WCCP and CPU Utilization

Unanswered Question
Jul 8th, 2009

Hi everybody, this is the case:

I have a Cisco 7609 (IOS Version 12.2(33)SRA6)which has a External Cisco Content Engine connected (WAE-7341).

I have configured wccp in Cisco 7609 and it seems to be working very well for about 1 month, however CPU proccess utilization in cisco 7609 is about 60% since I activate wccp.

Do you know/have any recomendation about WCCP configuration to avoid increase of CPU utilization?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ananshah Wed, 07/08/2009 - 13:49

Hello William ,

please check the following :

show ip wccp detail

and check the following "Assignment" field..

If the assignment field is hash then the packets are sent to cpu but if the filed is mask then the packets would be HW switched

In case of mask please check the if redirect is is or out and you might wana change it and check if that makes any diff..

william.tituana Wed, 07/08/2009 - 14:29

Hi, thanks for your answer..

the "assigment" field is "hash" and I think it must be "mask", isn't it? I think i can configure that parameter in WAE but what would be the mask? It seems to be an hexadecimal number. What is the number I have to configure?


ananshah Wed, 07/08/2009 - 14:56

Hey william ,

I am not good at WAE and stuff but may but you can try

wccp web-cache router-list-num mask-assign

Also what is the ios version you are running ?



Joseph W. Doherty Wed, 07/08/2009 - 17:07

Not 100% positive, especially with regard to a 7600, but recall impact on WCCP might also depend on whether the redirection is done at L2 or L3 (i.e. whether the redirected destination is on a directly connected subnet or not [GRE]).


Other possible issues might be, whether an ACL is used to narrow the traffic being redirected and/or whether redirection is being done on ingress or egress interface, and/or "redirect in" vs. "redirect exclude in".


This Discussion