back-to-back router connectivity

Unanswered Question
Jul 9th, 2009
User Badges:

Dear Friend,

I have a testing setup, descriptions are followings:-

1)Two cisco 3845 routers with 5 remote locations with leased line links, connected with serial ports of router each.

2)Both routers are connected with gigabiethernet ports.

3) OSPF routing protocol is used for routing with serial links and gigethernet ports except gigabitethernet ports which is connected back-to-back.

4)Independetly each routers are communication with remote locations and its LAN network.


Test1:

IN back-to-back connected gigabitethernet ports, I am using default routes, but i'm unable to commuicate both routers.

Router-1

Router1(config)#int gigabitethernet1/0

Router1(config-if)#ip add 170.128.0.y 255.255.255.0

Router1(config-if)#no shut

Router1(config)#ip route 0.0.0.0 0.0.0.0 170.128.0.x

Router-2

Router2(config)#int gigabitethernet1/0

Router2(config-if)#ip add 170.128.0.x 255.255.255.0

Router2(config-if)#no shut

Router2(config)#ip route 0.0.0.0 0.0.0.0 170.128.0.y


Test2:

I have tested for back-to-back gigabitethernet ports with ospf routing but not successful.

Router-1

Router1(config)#router ospf 100

Router1(config-router)#network 170.128.0.0 0.0.0.255 area 0

Router-2

Router2(config)#router ospf 100

Router2(config-router)#network 170.128.0.0 0.0.0.255 area 0



Kindly suggest me what need to do on both routers for back-to-back connectivity with gigabitethernet ports, so that my setup will be ready.Your suggestions will be appreciable.


Regards,

Siddhartha Singh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Istvan_Rabai Thu, 07/09/2009 - 02:17
User Badges:
  • Gold, 750 points or more

Hi Siddhartha,


My supposition is the following:


You may have connected the routers back-to-back on the GigabitEthernet ports using a straight-through patch cable.


Please check the output of the following command on both routers:


show interface GigabitEthernet x/y


Check in the output if both interfaces are in "up up" status.

You should see something similar to this:

"GigabitEthernet x/y is up, line protocol is up"


If not, change the patch cable to a crossover cable.


Cheers:

Istvan

siddindia Thu, 07/09/2009 - 03:45
User Badges:

hi Istvan,

I have checked Straight-through cable but in my both testing case i'm unable to ping serial port's IP address.

I have checked gigabiethernet ports in both router, they UP and line protocol is UP.


Regards,

Siddhartha

smothuku Thu, 07/09/2009 - 02:21
User Badges:
  • Silver, 250 points or more

Hi sidhhartha ,


directly connected interfaces will ping each other without any route or protocol...remove that default route pointing towards gig interfaces of other router.


you must use cross cable for connecting gig interfaces back to back as both are routers.


Most probably you are using straight cable...


After that paste show int g0/1 output of both the routers...


instead of giving whole the subnet give /32 network and check it once...



Cheers

MSK :)

siddindia Thu, 07/09/2009 - 04:10
User Badges:

hi MSK,

I'm not getting you in last lines.

"After that paste show int g0/1 output of both the routers...


instead of giving whole the subnet give /32 network and check it once... "


Please clear it

Cheers,

Siddhartha

siddindia Thu, 07/09/2009 - 20:28
User Badges:

Hi MSK,

Its true i'm using straight cable.but i'm pinging directly connected gig port.

The problem is in routing.i'm not able to ping any serial ports of another router from one router even i'm using default routing or dynamic routing.

What can i do, so that my routing will be perfect.


cheers,

Siddhartha

smothuku Thu, 07/09/2009 - 21:51
User Badges:
  • Silver, 250 points or more

Hi ,


Can you paste the config of the routers......


MSK :)

siddindia Fri, 07/10/2009 - 01:15
User Badges:

Hi MSK,

I'm sending "show config" output with attachment.

I've tested straight cable and cross cable between both routers through gigethernet ports.Ports will UP in both cases.

I'm still facing problem of routing, unable to ping serial ports from other router.

I think there is issue of routing of back-to-back connectivity.

Kindly help me.


Regards,

Siddhartha



Siddhartha



Attachment: 
smothuku Fri, 07/10/2009 - 03:16
User Badges:
  • Silver, 250 points or more

Hi Siddhartha ,


Try with below config :


interface Tunnel12

description GRE tunnel between FHQ and Tekanpur

ip address 192.168.11.2 255.255.255.0

qos pre-classify

tunnel source Serial1/0

tunnel destination 10.10.90.1

crypto map VPN-slc


interface GigabitEthernet0/0

description BACK-TO-BACK

ip address 170.128.0.9 255.255.255.0

ip ospf message-digest-key 1 md5 BSF_AMS

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

ip address 200.100.1.1 255.255.255.0

ip ospf message-digest-key 1 md5 BSF_AMS

duplex auto

speed auto

media-type rj45

!

interface Serial1/0

description SilchAR

--More-- ip address 10.10.90.2 255.255.255.0

encapsulation ppp

ip ospf message-digest-key 1 md5 BSF_AMS

serial restart-delay 0

crypto map VPN-slc

!


ip access-list extended VPN-slc

permit icmp 0.0.0.0 255.255.255.0 0.0.0.0 255.255.255.0

permit gre host 10.10.90.2 host 10.10.90.1



second router :


interface Tunnel12

description GRE tunnel between FHQ and Tekanpur

ip address 192.168.11.1 255.255.255.0

qos pre-classify

tunnel source Serial1/0

tunnel destination 10.10.90.2

crypto map VPN-TKP

!

interface GigabitEthernet0/0

description BACK-TO-BACCk

ip address 170.128.0.10 255.255.255.0

ip ospf message-digest-key 1 md5 BSF_AMS

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

interface Serial1/0

description Tekanpur

--More-- ip address 10.10.90.1 255.255.255.0

encapsulation ppp

ip ospf message-digest-key 1 md5 BSF_AMS

serial restart-delay 0

crypto map VPN-TKP


ip access-list extended VPN-TKP

permit icmp 0.0.0.0 255.255.255.0 0.0.0.0 255.255.255.0

permit gre host 10.10.90.1 host 10.10.90.2


You need to do extend ping for serial interfaces as crypto map is applied to these interfaces.....


you can do normal ping for back-to-back connected g0/0 interfaces


MSK :)

Actions

This Discussion