SMTP

Unanswered Question
Jul 9th, 2009

Hey all,

Seems simple enough but it isn't working. I have the SMTP server set in the CME to the IP of my Barracuda Spam firewall and I have allowed traffic for that IP. However, I looked in the logs of the Barracuda and no messages are hitting that box from the UC Unit. Is there an easy to fix this or to tell why the SMTP traffic isn't routing properly?

Thanks,

Jorge

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Thu, 07/09/2009 - 17:26

Jorge,

From you explanation I assume that you mean port forwarding? If so, did you do this with CCA or CLI? POrt forwarding in IOS is essentially a static NAT rule plus allowing that traffic through the applicble ACL's. What do you have?

Marcos

jorgediaz77 Thu, 07/09/2009 - 18:14

Marcos,

Sorry, my explanation was a bit misleading. This is in regards to the voicemail to email functionality. I have enabled email notification through the CME and I set the External SMTP server to my Barracuda. However, when a user receives a voicemail it isn't being transferred into their email. They don't want to use the IMAP configuration.

Thanks,

Jorge

jorgediaz77 Thu, 07/09/2009 - 18:41

Yup, everything is set up, SMTP server and authentication is configured. The users are enabled and configured to allow all messages to be delivered any time they are received. But no messages are being sent into exchange.

Marcos Hernandez Thu, 07/09/2009 - 18:48

Log into CUE and do a "trace smtpclient all", then a "show trace buffer". That should give us some hints on what's going on.  To disable tracing do "no trace all".

Thanks,


Marcos

Marcos Hernandez Thu, 07/09/2009 - 19:13

There is unnecessary output here. Can you do a "no trace all", then a "clear trace buffer", then enable the SMTP traces and collect the output again?

Make sure you wait long enough for the system to try to send the email.

Thanks,

Marcos

jorgediaz77 Thu, 07/09/2009 - 19:28

OK, So I cleared the buffer, re-enabled the SMTP logging, called in and left two seperate voicemail messages and this is all that was spit out:

4158 07/09 22:18:37.386 ACCN STGN 0 Task: 23000049973GetListMember: output string:outcall

4159 07/09 22:23:06.041 ACCN STGN 0 Task: 23000049976GetListMember: output string:outcall

Marcos Hernandez Thu, 07/09/2009 - 19:48

Hmm. We should at least see CUE trying to establish the TCP session.


Try to disable and re-enable notifications. If that doesn't work, reload the CUE module.


Finally, try to telnet to the SMTP server (port 25) from the UC500 and issue a "HELO" to verify you have connectivity.

You can verify proper configuration with "show voicemail notification owner XXX email"

Let us know,

Marcos

jorgediaz77 Fri, 07/10/2009 - 06:36

OK, I did everything but the reload and the info looks the same. I'll have to wait until after 3PM to run the reload since they are open until then. I'll repost results after that, however, just for informational purposes her is the buffer and email config dump:

UC500-CUE# show trace buffer
Press to exit...
4158 07/10 09:19:59.340 ACCN STGN 0 Task: 23000050061GetListMember: output string:outcall
4159 07/10 09:20:30.838 ACCN STGN 0 Task: 23000050062GetListMember: output string:outcall
4158 07/10 09:20:53.657 ACCN STGN 0 Task: 23000050063GetListMember: output string:outcall
4159 07/10 09:24:47.418 ACCN STGN 0 Task: 23000050069GetListMember: output string:outcall
4158 07/10 09:24:55.718 ACCN STGN 0 Task: 23000050070GetListMember: output string:outcall
4159 07/10 09:26:19.285 ACCN STGN 0 Task: 23000050076GetListMember: output string:outcall

UC500-CUE# show voicemail notification owner bneil email
Profile:             vm-notif-profile
Device:              Email Inbox
Enabled:             Yes
Preference:          All
Email address:       [email protected]
Text:                Voicemail Message
Attach Message:      Yes
Schedule(active hours):
Sunday:     Active all day
Monday:     Active all day
Tuesday:    Active all day
Wednesday:  Active all day
Thursday:   Active all day
Friday:     Active all day
Saturday:   Active all day

(the domain name is blanked for security reasons)

jorgediaz77 Fri, 07/10/2009 - 12:57

OK, I reloaded CUE and got the same result from the logs.

4159 07/10 15:53:52.869 ACCN STGN 0 Task: 23000050872GetListMember: output string:outcall
4158 07/10 15:53:58.106 ACCN STGN 0 Task: 23000050873GetListMember: output string:outcall
4160 07/10 15:54:03.190 ACCN STGN 0 Task: 23000050874GetListMember: output string:outcall
4159 07/10 15:54:48.911 ACCN STGN 0 Task: 23000050876GetListMember: output string:outcall

Marcos Hernandez Fri, 07/10/2009 - 14:44

Jorge,


Did you try to Telnet to the SMTP port on your server? What happens when you do that? This will work if you are not using encryption.

Thanks,


Marcos

jorgediaz77 Fri, 07/10/2009 - 14:58

Yes, I was able to telnet to port 25 and run a helo command from the UC to the Mail server.

Thanks,

Jorge

Marcos Hernandez Fri, 07/10/2009 - 15:00

OK. Jorge, I am afraid that you will need to open a TAC case so they can investigate further.


Thanks a lot,

Marcos

jorgediaz77 Fri, 07/10/2009 - 17:57

Marcos,

Thanks for the help. I'll go ahead and open a TAC case and let you know what they find.

Thanks,

Jorge

jorgediaz77 Wed, 07/22/2009 - 06:30



Well that was an interesting journey. TAC ran some diagnostics and found the following DB error:

<195>Apr 28 12:16:45 localhost j9:   ERROR dbclient database mgmt **** ERROR: column "smtpserver" does not exist

His solution was to backup, reinstall and restore CUE. I ended up comparing the CUE running config to a similar setup and found an incorrect gateway address under the ccn subsystem sip:
ccn subsystem sip gateway address "10.1.1.1" dtmf-relay sip-notify end subsystem I changed this, saved and rebooted and messages began to be delivered. Yaay, no need to reinstall CUE!

Thanks again for the assist!

We are having a similar issue in that we cannot get Voicemail to email via SMTP.  We have also configured Fax to Email and it works fine, so we know the UC can talk to the SMTP server.  As for your fix, it would seem that our DG points to the ISM so this seems correct

ccn subsystem sip
gateway address "10.1.10.2"
dtmf-relay sip-notify
end subsystem

Actions

This Discussion