Call-Forward all to PSTN with multiple UC500s

Unanswered Question

HI There,

slight issue with two (or more) UC500s connected via VPN - All internal calls work fine between systems, as do external from each to local PSTN.

The problem I am finding is when an ephone-dn is forwarded to a mobile(cell) phone for example Internal number 3401 call-forward all 907555XXXXXX ( 9 is used to diect via ISDN in the UK) if the call originates from another UC500, then the call is made from "source" UC500 when I actually want the call made from the "destination" UC500.

This is not an issue with two systems in the same country, since they will generally have a route out in the same manner, but when an International UC500 (for example Singapore) tries to call internal 3401, the source UC500 in SIngapore attempts to dial the exact number "807555xxxxxx" instead of letting the destination UC500 route the call.

Calls inbound via ISDN or Private VPN SIP from say a Mitel PBX work correctly, only Cisco to Cisco where we have the problem.

Can someone suggest a way of doing this?   Note I do not want to translate calls from singapore to International nummber eg "+447555xxxxx" I want the destination PBX to route the call and have toll charges.

Thanks,

Peter.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Mon, 07/13/2009 - 12:38

On the UK side, can you add this:

telephony-service

transfer-system local-consult

Let me know,


Marcos

Marcos Hernandez Mon, 07/13/2009 - 12:43

If the above doesn't do the trick, try disabling all forms of H.450 by negating the command each time:

UC500(conf)#voice service voip

UC500(conf-voi-serv)#supplementary-service ?
  h225-notify        enable/disable h225 notify control
  h450.12            enable/disable H.450.12
  h450.2             enable/disable H.450.2
  h450.3             enable/disable H.450.3
  h450.7             enable/disable H.450.7
  media-renegotiate  enable/disable Media Renegotiation
  ringback           enable/disable ringback signal
  sip                sip supplementary service

Marcos

Marcos Hernandez Wed, 07/15/2009 - 04:49

Glad to hear that. There should not be unintended consequences, but let us know if you find something out of the ordinary.

Thanks,


Marcos

Hi Marcos,

I now have had this happen in multipe sites - If "transfer system local-consult" is set, then more often than not inbound calls coming in the UC500 from an E1 or BRI fail when attemoting a local transfer to an IP phone - either the call competlely drops or it just refuses to transfer.

I have had to change back to full-consult and as a result the mobiles are not working again.

Do you have any ideas?   Note it is intermittant.

note all dn are dual-line (or octo)

Thanks,
Peter.

Saurabh Verma Tue, 09/08/2009 - 05:46

Hi Peter,


As Marcos indicated earlier, try disabling H/323 supplementary service:

UC520#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
UC520(config)#voice serv voip

UC520(conf-voi-serv)#no supplementary-service h450.2
UC520(conf-voi-serv)#no supplementary-service h450.3
UC520(conf-voi-serv)#no supplementary-service h450.7
UC520(conf-voi-serv)#no supplementary-service h450.12

UC520(conf-voi-serv)#end


Thanks,

Saurabh

Actions

This Discussion