ACL to block broadcast and multicast on one switch port

Unanswered Question
Jul 12th, 2009
User Badges:

Hello,


This is probably going to be a very easy question for most of you but it would help me quite a bit.


What I want on one of our 3560 series switches is to prevent any broadcast and multicast traffice going to a port.


The reason for this is that there is a router behind it (not ours but supplied by our telecom company) which makes a connection to another office and I want the line (as its not a very big one) to be as clean as possible.


Its probably going to be something like this but just not sure if this is correct :


access-list 10 deny 255.0.0.0 0.255.255.255

access-list 10 deny 224.0.0.0 7.255.255.255

access-list 10 permit any


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (2 ratings)
Loading.
stefanmansier Mon, 07/13/2009 - 03:25
User Badges:

So should I use protected ports instead ?

The article doesn't mention ACL's.

thotsaphon Mon, 07/13/2009 - 04:47
User Badges:
  • Gold, 750 points or more

Stefan,

Do you really want to do that way? (grin)

!

Switch(config)# interface gigabitethernet X/Y

Switch(config-if)# storm-control multicast level 0

Switch(config-if)# storm-control broadcast level 0

!



Let's start from here: http://www.cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.2_44_se/configuration/guide/swtrafc.html


HTH,

Toshi


ajenks Fri, 10/21/2011 - 08:09
User Badges:


I am just looking at this document for a similar requirement as the original post - but isn't storm control for Ingress traffic?

ajenks Fri, 10/21/2011 - 09:12
User Badges:

Sure - but the original post was about not forwarding this traffic OUT through a specific port, so Egress (something I want to do) but dont think this is possible?

cadet alain Fri, 10/21/2011 - 10:32
User Badges:
  • Purple, 4500 points or more

Hi,


if you do this


Switch(config-if)# storm-control multicast level 0


Then no more traffic will enter the port as soon as multicast packet enters the port   because storm-control for multicast wiil block unicast also when the threshold is hit.


Alain.

kishan1984 Tue, 07/14/2009 - 04:34
User Badges:

try enabling igmp snooping(default is enable) and also type one command to enable switch to itself function as a igmp querier.

Actions

This Discussion