FXO + FCT DTMF recognition

Unanswered Question
Jul 13th, 2009


I have an FXO connected to a GSM FCT. Whilst I can hear the IVR menu (bacd) it does not seem to recognize the DTMF tones. How could I debug to see if the DTMF tones are actually received at the FXO port.

Relevant config:

voice-port 0/2/0

trunk-group MobileOut

supervisory disconnect anytone

no battery-reversal

echo-cancel coverage 24

compand-type a-law

timeouts call-disconnect 3

timeouts wait-release 3

connection plar opx 6901

caller-id enable



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
pcameron Mon, 07/13/2009 - 15:00

When a key is pressed on a mobile handset, DTMF tone is not generated locally. A key command is sent to the mobile switching center (MSC), similar to the way DTMF relay works from IP phones.

If the call terminates on a PSTN landline, The MSC generates the DTMF tones and it goes out as inband audio towards the landline.

In the other direction (PSTN to mobile phone) there is normally no out of band command sequence that the wireless network can send to a mobile handset to indicate DTMF tones/keys.

GSM interworking units are not set up to be able to detect DTMF tone either. So the DTMF tone is carried inband in the GSM link wirelessly to a mobile handset.

Your GSM device will be emulating a mobile handset to talk to the mobile network. Therefore the DTMF tone it receives from GSM network has already been distorted by the GSM codec, and the digits will not always be passed reliably.

since the GSM unit is simply passing the tone, then the FXO interface and DSP will have to perform the detection on a poor quality signal which may mean low reliability

One thing you do need to do is to get rid of the command 'compand-type a-alaw' off the voice port config. It is only needed if the interface is digital (BRI or PRI) and it can potentially cause a-ulaw mismatches internal to the system. These result in distorted audio as well. It may help with the DTMF detection by defaulting the setting.

apats Tue, 07/14/2009 - 07:50

Thank you for your message Paul, very informative.

Tried removing 'compand-type a-law' but still no luck.

It would be useful to verify incoming tones, even distorted, wondering how I could do this.

Thanks again.


This Discussion