Unable to get TFTP Config to IP Phone

Answered Question
Jul 13th, 2009
User Badges:
  • Blue, 1500 points or more

hi experts,


i have a 3845 router and 3560 switch. i had an issue wherein i can't get my 1140e nortel ip phone settings (server unreachable) when connecting to 3560e switch. previously i was able to have it worked during my initial config (ip addressing, vlan and interface vlan configs) for the switch and router. and then i've added acl, qos etc along the way. then i tested my ip phone again, it doesn't get its config. from the switch, i can ping to our dhcp (172.25.22.10) and nortel pabx server (172.25.202.15) from vlan voice (vlan 1076) as source. i used the ip phone to troubleshoot, i can ping to the voice gw (172.25.227.253). my belief there's a line or config blocking my connection. i've exhausted all troubleshooting needed all day. i need a fresh set of eyes to look into my config and verify with me so that i can continue testing tomorrow. thanks in advance!



Correct Answer by Collin Clark about 8 years 1 week ago

We ended up hard setting the information in the phones instead of using the DHCP options. We couldn't get it to pass everything correctly. I've attached a Nortel DHCP configuration guide.


Hope it helps.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
xcz504d1114 Mon, 07/13/2009 - 04:56
User Badges:
  • Bronze, 100 points or more

I don't see any ip helper address on your router. Also check your DHCP server and make sure option 150 is set.


-Edit- I looked over the configs again when I got to work, you have your helper-addresses on the switch, the only thing left is Option 150.


HTH,

Craig

Giuseppe Larosa Mon, 07/13/2009 - 05:20
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello John,

your configuration looks like fine.


Sorry for the basic question:


Have you checked the presence of option 150 in the DHCP scope for the IP subnet associated to vlan1076 on the DHCP server(s) ?


I don't see any ACL on the two devices

And where is pabx server 172.25.205.15 check all the path to it


Hope to help

Giuseppe


xcz504d1114 Mon, 07/13/2009 - 05:52
User Badges:
  • Bronze, 100 points or more

Good to know! Thanks Jerry.


Craig

thotsaphon Mon, 07/13/2009 - 06:13
User Badges:
  • Gold, 750 points or more

John,

Are you running a routing protocol between these two devices? Please post the entire configuration on Sw3560.

- Your uplink is in vlan 124(access port).


- How does router know about vlan 1076? Do you want to add static route to route it back or run routing protocol(ospf) on both devices?

Well, You've used a static route. I'm glad to see a redistribute static there (grin)


- Seems you need Sw3560 to act as L3 switch. Please post a "show ip route" command on this switch . I need to know things.

- Please let me know if you pretend to be vlan 1076 from the existing configuration on Sw3560(just one port for testing) you will then get these 2 servers ,172.25.202.15 and 172.25.22.10. Does it work? (grin)


- Please post a "show ip route" command on the router.


Before talking about the dhcp option I would know what your network path looks like.


John,I assumed things as follows:


#####For switch3560######


!

ip routing

!

no ip default-gateway 172.25.124.253

!

ip route 0.0.0.0 0.0.0.0 172.25.124.253

!




HTH,

Toshi


Correct Answer
Collin Clark Mon, 07/13/2009 - 06:06
User Badges:
  • Purple, 4500 points or more

We ended up hard setting the information in the phones instead of using the DHCP options. We couldn't get it to pass everything correctly. I've attached a Nortel DHCP configuration guide.


Hope it helps.



johnlloyd_13 Tue, 07/14/2009 - 02:03
User Badges:
  • Blue, 1500 points or more

thanks for everyone's inputs. but collin did the job! config and routing was working properly. it's just the ip phone settings that had the problem.

Actions

This Discussion