Caller ID

Answered Question
Jul 13th, 2009

Hello

Just set up uc 500 from cca sofware with 2 bri interfaces all works fine except incoming caller id strips the leading zero. I searched on here but cant find a simple solution.

Could someone explain in relative laymans terms how to do it

Thanks

I have this problem too.
0 votes
Correct Answer by Eivind Jonassen about 7 years 4 months ago

Andrew,

How does your current incoming dial-peer look like?? Could you post the dial-peer and translation rule??

It looks like there's a easy way to fix this, if your current incoming translation profile is still voice "translation-profile Work-BG_Called_6", then add the following:

voice translation-profile Work-BG_Called_6
translate called 6

translate calling 10001

Edit rule:

voice translation-rule 10001

rule 1 /^\(.*\)/ /0\1/

no rule 2

Regards,

Eivind

Message was edited by: Eivind Jonassen

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Skyler Spence Mon, 07/13/2009 - 09:19

andrewsymms wrote:

except incoming caller id strips the leading zero.


By this do you mean that the calling party's number has a leading 0 stripped, and so it is showing incorrectly on the phones?  Or the called number's 0 is being stripped and the call is failing to route correctly?  Or is 0 your steering digit to select an outbound call, and you wish to press dial directly from the phone when viewing missed or received calls?  Please clarify so we can better help.

andrewsymms Mon, 07/13/2009 - 10:27

Yes first assumption was correct the calling parties number displays on the phone less the leading digit as per 01935425653 displays on the phone as 1935425653

Skyler Spence Mon, 07/13/2009 - 11:40

Ok, could you post your configuration with the usernames and passwords removed?  I'll check the dial peers and translation rules to see if anything may be stripping the digit.

Skyler Spence Tue, 07/14/2009 - 07:36

Can you please session into the box and enable the following debug commands:

debug isdn q931

debug voip dialpeer


term mon

Then make a test call and capture all the output and attach it here.  Very important, once you are done enter

u all

term no mon

to return your system to normal.  Thanks.

Skyler Spence Tue, 07/14/2009 - 08:57

Andrew,

This debug shows that the calling number is not being sent with a leading 0, this is something you will need to contact your telco provider about.  If the incoming number the system is given doesn't have a 0, we don't put one there!  Though if you need, it is relatively simple to add a 0 to the front of all calling numbers...

andrewsymms Tue, 07/14/2009 - 09:12

Hello

Ive spoken to the telco and they advised me they may not be able to do that so if you could advise me how i can do it within the system would be appreciated

Thanks

Skyler Spence Tue, 07/14/2009 - 11:29

I am not wholly familar with UK dialplans, so first let me confirm one thing.  Do you want ALL incoming numbers to have a leading 0 added?  This is relatively simple to do, but if you want only one type of number (long distance or mobile for example) to have a leading 0 it becomes much more complicated.

gsgilbeson Tue, 07/14/2009 - 13:42

without wishing to hijack the thread/discussion, but i would like to know how to add the leading 0 to all calls?

many thanks

andrewsymms Wed, 07/15/2009 - 00:15

I think if I could just get it to add a zero to all calls that might do the trick. If I call from a local number the display on the phone gives the full national number. eg calling from 433925 seems to give 1935433925 which should be 01935433925. However that might just be from that particular number I suppose.

gsgilbeson Tue, 07/14/2009 - 08:50

I am having the exact same issue as Andrew,  the leading 0 is being stripped and isn't being shown on the display of the handsets when callers dial in!

Thanks in advance

Skyler Spence Wed, 07/15/2009 - 08:17

Prepending a 0 to the beginning of all incoming calls involves adding a translation rule to do so, including this rule in the "calling" portion of a translation profile, and using this translation profile with all your incoming dialpeers.  When making all these changes through CLI, please follow the guidelines in this document to ensure CCA compatibility.

http://www.cisco.com/en/US/docs/net_mgmt/cisco_configuration_assistant/version2_0/out_of_band_reference/cca_20_oob_config_guidelines.pdf

The procedure itself is very similar to adding a 9 to inbound calls so that missed calls can be directly dialed from the missed calls menu.  This procedure is outlined here: https://www.myciscocommunity.com/message/6010#6010

First create a translation rule that matches your local dialplans.  For example locally most numbers calling me have 10 digits, so to add a 0 to the beginning I could do

voice translation-rule 10001

rule 1 /\(^..........$\)/ /0\1/

rule 2  /\(^.*\)/ /0\1/

Notice that the second rule literally matches any string of digits, so it could be all you use.  Now, create a translation profile that uses this rule on all calling numbers:

voice translation-profile ADD_ZERO

translate calling 10001

Be sure to examine your existing configuration to determine if further rules need to be applied to your incoming calls.  Finally, configure all your incoming dial-peers to use this translation profile and you're done.

andrewsymms Wed, 07/15/2009 - 12:21

Thanks so far but im not sure how to do this bit "configure incoming dial peers to use this new rule"

Skyler Spence Wed, 07/15/2009 - 12:25

Locate your incoming dial peers, CCA will helpfully label these for you, and you will see a configuration such as

dial-peer voice 702 pots
description ** FXO - 0/1/2: incoming dial peer matching one or more digits *
translation-profile incoming POTS_CALLBACK
incoming called-number .%
port 0/1/2

as a rule of thumb if there is an "incoming called-number " configured on the dial-peer it is an inbound dial-peer.  You can change the translation-profile incoming ******** so that your new translation-profile is used.

andrewsymms Thu, 07/16/2009 - 15:23

hello

Ive got this far if you could have a look at the atached file

I can either connect the call or add leading zeros !!

Is there something obvious im missing

thanks for your patience

David Trad Thu, 07/16/2009 - 17:02

Hi Andrew,

Your configuration should look something like this (Based upon your posted running config):

voice translation-rule 2001
rule 1  /\(^.*\)/ /0\1/

Then

voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate calling 1111
translate called 1112

translate called 2001

Again i just used your posted config for this, instead of creating multiple translation profiles, you can use the same one as before, this way you dont have to modify the dial-peers, however in doing this, it would mean that all outbound calls no matter what will get a leading zero, this is due to using the capture all translation-rule.

So you are only really creating an extre voice translation-rule 2001

I havent tested this but i am sure it will work.

Cheers,

David.

andrewsymms Fri, 07/17/2009 - 00:30

Hello

Thankyou

That works but the wrong way round puts a leading zero on outgoing calls.

I need it to add a zero to the incoming calls

Andrew

David Trad Fri, 07/17/2009 - 00:46
That works but the wrong way round puts a leading zero on outgoing calls.

DOH!!!!!!!!!

I must have mis-understood what you said, i thought you wanted the Zero added to the number so you could press redial for all calls... My Bad.

Ok i will look at your original config and work it out, sorry for that.

Cheers,

David.

Correct Answer
Eivind Jonassen Fri, 07/17/2009 - 00:48

Andrew,

How does your current incoming dial-peer look like?? Could you post the dial-peer and translation rule??

It looks like there's a easy way to fix this, if your current incoming translation profile is still voice "translation-profile Work-BG_Called_6", then add the following:

voice translation-profile Work-BG_Called_6
translate called 6

translate calling 10001

Edit rule:

voice translation-rule 10001

rule 1 /^\(.*\)/ /0\1/

no rule 2

Regards,

Eivind

Message was edited by: Eivind Jonassen

andrewsymms Fri, 07/17/2009 - 10:17

Thankyou so much.

As a complete novice to this new phone system and having spent a long time scratching my head youve solved my dilema. with your simple solution I now have leading zeros !!

Im not sure if the leading zero problem was just relevant to me and my telco or a UK based scenario but hopefully if anyone else has the same issue they can look here to find the answer

Please see attached file.

Thankyou again.

Andrew

Attachment: 
Eivind Jonassen Fri, 07/17/2009 - 11:14

Andrew,

Glad to help :)

This is not just related to you or the UK, this is a global "problem". When you get a hang of the translation rules and the dial-peers they are quite powerful, my recommendation is that you play around with the translation rules as you can manipulate whatever numbers you want, both incoming and outgoing (for outgoing it´s dependent on your telco).

Glad to hear you were able to solve your "problem"

Regards

Eivind

gsgilbeson Fri, 08/14/2009 - 02:47

Eivind,

I followed your instructions, and encountered an error!

I two am an UK user, and our telco doesn't send leading 0!

So as per your post, I created an additional translation rule 10001 with the correct string, and added that to our AA profile (Main-AA_Called_4), (calling portion of it!) as per your post.

When our main number is called, the caller pushes 1 as per AA greeting, you hear one ring, then a dead tone!

If i remove rule 10001 from the calling portion of AA profile (Main-AA_Called_4), when pushing 1 on AA queue, everything works as per normal!

Having looked thru my config, i'm pretty sure that the dialpeer uses Main-AA_Called_4 and not AA_Profile.

I have included a copy of my config.

Any help would be appreciated.

Eivind Jonassen Fri, 08/14/2009 - 09:08

gsgilbeson,

I´m not 100% sure on this one, but have you tried adding the "calling 10001" on both Main-AA_Called_4 and AA_Profile, just a quick check to see if it´s working or not. It looks like you use both dial-peers, 3000 and 3001 for calls made towards the UC (from BRI) and 2003 towards the CUE (AA).

What you should do is to do a "debug ccsip calls" this would get you a basic idea what´s happening after the call reaches the CUE, as I understood the call was terminated after reaching AA and pressing 1. The output from this debug should be able to show you the reason for the disconnection. You probably should do a "debug voice translation" as well to check the number manipulation.

Thanks,

Eivind

Message was edited by: Eivind Jonassen

I would also try changing your script. Have you made this yourself?? Try setting the AA to a script which only has opening hours, and not dial options for the user, just to double check that it´s not your script with dial options that is causing your disconnection.

gsgilbeson Fri, 08/14/2009 - 11:21

Elvind,

Thanks your reply, i will test on monday when at site.

I was going to try and add rule 10001 to both the mentioned profiles, but i couldn't see a where AA-Profile was referenced.

The AA script i use is one of the default ones.

Many thanks

Eivind Jonassen Fri, 08/14/2009 - 11:25

gsgilbeson,

Also, if your not able to solve this on monday with the mentioned options, you should start a new thread as this one is already marked as answered and you probably would get more help (at least from the cisco guys) if you start a new one. Have a great weekend

Thanks

Eivind

Steven Smith Wed, 07/15/2009 - 12:26

Using Skylers example...

config t

dial-peer voice

voice translation-profile incoming ADD_ZERO

Actions

This Discussion