CM7 with CUE7 no audio

Unanswered Question
Jul 13th, 2009

The problem is I dial my voicemail pilot number, the call is picked up but I don't get any audio output from Unity. I would expect the usual 'Please enter your PIN' etc…

I am running:

Cisco Unified CM Administration (7.0.2.20000-5)

Cisco Unity Express version (7.0.3) This is running on an NME on a 2821 (12.4(13r)T11), I upgraded from the 3.2.0 that was on the card originally as CUE was not able to identify the CTI ports from CM. I have setup my CTI device ports, Route ports and User with associated devices, these all register with CM ok. When I dial the pilot number I can see the call being picked up by the individual voice ports in a round robin fashion. When I verify my CM setup from the CUE GUI this returns 'successful' for both Web & JTAPI.

I have followed the below guide but it still have the above result:

http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_configuration_example09186a0080289ef0.shtml

I have done a packet sniff on my IP phone filtering on just RTP packets, when I dial unity I can see packets from the phone going to the CUE IP but nothing coming back in the other direction!

I'm not sure if the 'Configure Transcoding' section is where I'm going wrong as it states this is optional although not all the commands were accepted by my IOS. I have looked further into the SCCP config and I get the below result:

router#show sccp

SCCP Admin State: UP

Gateway Local Interface: GigabitEthernet0/0

IPv4 Address: 10.17.100.170

Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 10.17.100.150, Port Number: 2000

Priority: N/A, Version: 7.0, Identifier: 1

Trustpoint: N/A

Transcoding Oper State: ACTIVE_IN_PROGRESS - Cause Code: NOT_REGIS_WITH_CCM

Active Call Manager: NONE

TCP Link Status: NOT_CONNECTED, Profile Identifier: 1

Reported Max Streams: 10, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

Here is the config from my router:

router#sh run

!

! card type command needed for slot/vwic-slot 0/0

!

voice service voip

allow-connections h323 to h323

!

voice-card 0

dsp services dspfarm

!

interface GigabitEthernet0/0

ip address 10.17.100.170 255.255.255.128

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Integrated-Service-Engine1/0

ip unnumbered GigabitEthernet0/0

service-module ip address 10.17.100.160 255.255.255.128

service-module ip default-gateway 10.17.100.129

no keepalive

!

ip forward-protocol nd

ip route 10.17.100.160 255.255.255.255 Integrated-Service-Engine1/0

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

sccp local GigabitEthernet0/0

sccp ccm 10.17.100.150 identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate profile 1 register mtp002545f39320

keepalive retries 5

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 5

associate application

SCCP

!

telephony-service

sdspfarm units 1

sdspfarm transcode sessions 5

sdspfarm tag 1 mtp002545f39320

em logout 0:0 0:0 0:0

ip source-address 10.17.100.150 port 2000

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

end

Many thanks in advance for any help or guidance.

Matt

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mmoulson1 Thu, 07/16/2009 - 00:42

Ok, I have managed to take this a little further! I found that my CIPC softphone can hear unity! But only when 'optimize for low bandwidth' is disabled. This gave me the idea that it must be a codec issue. So I have tried to get the SCCP transcoder working.

I found the reason for the 'NOT_REGIS_WITH_CCM' Error was that I had not configured anything on my CM.

I have found many articles that suggest adding the transcoder as an MTP on CME, but nothing for CM. I have tried to configure it as transcoder and an MTP, at which point it shows as registered with the routers IP address. Regardless of which I add it to my SCCP status changes to 'Transcoding Oper State: ACTIVE - Cause Code: NONE'.

Should I set it up as an MTP or a Transcoder?

I've tried assigned it to my 'Media Resource Group' that is associated with my phones 'Device Pool' but I still get silent back when I dial Unity. How do I get the phones to actually use it?

Many thanks

Matt

Actions

This Discussion