call from PSTN keep ringing forever in my extension on the gateway 2811

Answered Question
Jul 13th, 2009

hi

i have a issue, when somebody make a call from pstn to my extension in the gateway, but i dont answer and the caller offhook the call, the ip phone keeps ringing forever....

the only way to stop ringing is disconnect the line from the fxo card.

this is the config on the gateway:

voice-port 0/3/0

supervisory disconnect dualtone mid-call

timeouts call-disconnect 1

timeouts wait-release 1

timing hookflash-out 50

connection plar 1003

!

dial-peer voice 2 voip

destination-pattern 1003

session target ipv4:192.168.1.230

!

this is the debug vpm signal:

ROUTER2811#

*Jul 13 16:01:11.218: htsp_process_event: [0/3/0, FXOLS_ONHOOK, E_DSP_SIG_0000]f

xols_onhook_ringing

*Jul 13 16:01:11.218: htsp_timer - 125 msec

*Jul 13 16:01:11.346: htsp_process_event: [0/3/0, FXOLS_WAIT_RING_MIN, E_HTSP_EV

ENT_TIMER]fxols_wait_ring_min_timer

*Jul 13 16:01:11.346: htsp_timer - 10000 msec

*Jul 13 16:01:11.694: htsp_process_event: [0/3/0, FXOLS_RINGING, E_DSP_SIG_0100]

*Jul 13 16:01:11.694: fxols_ringing_not

*Jul 13 16:01:11.694: htsp_timer_stop

*Jul 13 16:01:11.694: htsp_timer_stop3 htsp_setup_ind

*Jul 13 16:01:11.694: [0/3/0] get_local_station_id calling num= calling name= ca

lling time=07/13 16:01 orig called=

*Jul 13 16:01:11.698: htsp_process_event: [0/3/0, FXOLS_WAIT_SETUP_ACK, E_HTSP_S

ETUP_ACK]

*Jul 13 16:01:11.698: fxols_wait_setup_ack:

*Jul 13 16:01:11.698: [0/3/0] set signal state = 0xC timestamp = 0fxols_check_au

to_call

*Jul 13 16:01:11.702: htsp_process_event: [0/3/0, FXOLS_PROCEEDING, E_HTSP_PROCE

EDING]fxols_offhook_proc

*Jul 13 16:01:11.702: htsp_timer - 120000 msechtsp_alert_notify

*Jul 13 16:01:11.766: htsp_process_event: [0/3/0, FXOLS_PROCEEDING, E_HTSP_ALERT

]fxols_offhook_alerthtsp_call_service_msghtsp_call_service_msg not EFXS (2)

ROUTER2811#

to stop the call ringing forever, is disconeccting the line fom the fxo, this is the same debug when i diconnect the line:

ROUTER2811#

*Jul 13 16:01:19.878: htsp_process_event: [0/3/0, FXOLS_PROCEEDING, E_DSP_SIG_11

00]fxols_offhook_disc

*Jul 13 16:01:19.878: htsp_timer2 - 350 msec

*Jul 13 16:01:20.230: htsp_process_event: [0/3/0, FXOLS_PROCEEDING, E_HTSP_EVENT

_TIMER2]fxols_disc_confirm

*Jul 13 16:01:20.230: htsp_timer_stop

*Jul 13 16:01:20.230: htsp_timer_stop2

*Jul 13 16:01:20.230: htsp_timer_stop3

*Jul 13 16:01:20.234: htsp_process_event: [0/3/0, FXOLS_PROCEEDING, E_HTSP_RELEA

SE_REQ]fxols_offhook_release

*Jul 13 16:01:20.234: htsp_timer_stop

*Jul 13 16:01:20.234: htsp_timer_stop2

*Jul 13 16:01:20.234: htsp_timer_stop3

*Jul 13 16:01:20.234: [0/3/0] set signal state = 0x4 timestamp = 0

*Jul 13 16:01:20.234: htsp_timer - 2000 msec

*Jul 13 16:01:22.234: htsp_process_event: [0/3/0, FXOLS_GUARD_OUT, E_HTSP_EVENT_

TIMER]fxols_guard_out_timeout

*Jul 13 16:01:22.234: htsp_process_event: [0/3/0, FXOLS_ONHOOK, E_DSP_SIG_0100]

ROUTER2811#

I have this problem too.
0 votes
Correct Answer by Adrian Saavedra about 7 years 4 months ago

Hi,

There are some posts in Netpro about this type of problems.

Also read about this:

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00800ae2d1.shtml

Regards.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lwai Wed, 07/15/2009 - 00:56

Hi,

Under the voice port, you should define the cptone.

Regards,

Michael.

Actions

This Discussion