Voice data not loading in CCA

Unanswered Question
Jul 13th, 2009

Hi all,

I' ve been trying to get Historical Reporting working on my UC520 and in doing so have come across this problem with CCA: "Voice data not loading". It hangs at around 67% and because of this I'm unable to get to my IP phones to do any admin.

I've seen there are similar discussions relating to this, but I'm not sure I need to replace my UCE module as voicemail is still working. I'm thinking a cold start might fix the whole thing, but can anyone tell me what config I need to check so I can maybe fix this without needing a cold start? I can't really find anything specific on the web.

Also, can anyone give me any tips on the Historical Reporting client? I am able to see full Call History for all my phones through the Unified Communication Express web-gui, but the client only shows me call data for the voicemail system, so who has called voicemail, notification lights etc. It doesn't show me any calls from phones...

I haven't made any changes to the .ini files - they are as they were installed. Has anyone got any tips on this as well pls?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jorgediaz77 Mon, 07/13/2009 - 08:40


I ran into the same issue a few months back regarding the voice loads. The problem is most likely an 'out of band configuration' that the CCA can't interpret. Have you made any configuration changes to the system using the command line? This is what caused my problem, I had configured the LiveRecord functionality through the command line and couldn't load the CCA. What version of CCA are you using? I'd recommend using 2.0.1 as it seems to be the most stable at this point. 

I have also used the Historical Reporting client and personally am not a fan of it. Marcos helped me out a lot getting options, see the thread below for options on manually configuring the reporting to a  TFTP site or using a 3rd party like ISI.


Another great option is the CallConnector for Windows Server. It allows users to see personal call history through Outlook. The call history ends up getting stored in an MDB file so I created a linked table using Access and have a simple search query that managers can use to search for specific call history. It ends up working quite well. Hope this helps :)



NeilRice2009 Mon, 07/13/2009 - 09:05

Hi Jorge,

Thanks for coming back to me.

I'm running CCA 2.0. I was using the command line to try and setup Historical Reporting so the problem could well be an "out of band configuration". How did you manage to resolve the fault?

I'll check out the link on Historical Reporting. It maybe that I end up going with something like CallConnector.


jorgediaz77 Mon, 07/13/2009 - 09:11

Here is the out of band guide Steve provided me:


I generally make a backup prior to making any changes so I was able to isolate the issue by rolling back to a previous config. If you post your config I can take a peek to see if I can see where the out of band piece is, of course the Cisco guys on here can probably track it down quicker :)



NeilRice2009 Mon, 07/13/2009 - 10:00

Hi Jorge,

What config do you need? It's a lot of data...

Also, I did a sh run on the service module and a lot of error/info messages come up that didn't before. Have a look at the file attached.



jorgediaz77 Mon, 07/13/2009 - 10:07

You will want to log into the main UC500 and get into enabled mode, run 'show run' and capture that. I use Putty which is great for doing mass copies to text files.



NeilRice2009 Wed, 07/15/2009 - 02:27

Hi Skyler,

Thanks for the reply.

Excuse the ignorance (I'm a complete novice with this), but are you talking about these dial-peers:

dial-peer voice 50 pots

description ** incoming dial peer **

incoming called-number .%


port 0/1/0

dial-peer voice 51 pots

description ** incoming dial peer **

incoming called-number .%


port 0/1/1

And also similar dial-peers 150 and 151? If I've read the document right, they should be numbered in the 3000-4999 range. Is that right? I can't see anything wrong with the translation rule.

What I don't get from this (actually there's a lot I don't get!), is any changes I made were only to do with Historical Reporting. How come dial-peers and voice translation rules are wrong? I never changed any of that stuff...


Skyler Spence Wed, 07/15/2009 - 07:55

I'm referring more to

dial-peer voice 3010 pots
description mainnumber
translation-profile incoming mainnumber_Called_6
incoming called-number 800040
port 0/1/1

and the others like it.  The document does not mean for you to create incoming dialpeers in this range, it states

The following table lists dial-peer tag ranges that are reserved for use by CCA.  OOB dial-peers should be created in the 5011 - 5999 range.

It appears that this system has indeed been configured outside of CCA, I'm also curious as to why there are no users or phones configured on the system.

NeilRice2009 Wed, 07/15/2009 - 08:18

Doesn't that dial-peer just mean it was configured in CCA, and then CCA gave it a dial-peer number in the range it uses for Inbound call routing?

I left the phone and user data out of the config text I posted. I didn't think it was relevent since CCA was working before I tried to configure Historical Reporting on it.

Here's the full file.

Skyler Spence Wed, 07/15/2009 - 09:07

CCA would not have created that dial-peer, it uses a translation profile outside of CCA's defined values (which are shown in the OOB document) and a description that does not match a CCA given description.

NeilRice2009 Wed, 07/22/2009 - 04:07

Hi Skyler,

Well, last Thursday we had a network issue which forced a reboot of the UC520. Because I hadn't saved any config after I made changes (which caused voice-related data to not load), everything is now working fine and I'm able to access the Voice data.

Not exactly a solution, but I just wanted to let you know it's all working.

Thanks for your help,


This Discussion