WS-C3750-24PS-E can't get HSRP past INIT state

Unanswered Question
Jul 13th, 2009
User Badges:

Why wont HSRP go beyond the INIT state



interface Vlan20

description Zone2-6513-Blades 2-4

ip address 10.20.20.1 255.255.255.0

ip helper-address 10.20.40.48

no ip redirects

no logging event link-status

standby 20 ip 10.20.20.3

standby 20 priority 110

standby 20 preempt

!

interface Vlan40

description DataCntr 6513 Blades 3-4

ip address 10.20.40.1 255.255.255.0

ip helper-address 10.20.40.48

no ip redirects

no logging event link-status

standby 40 ip 10.20.40.3

standby 40 priority 110

standby 40 preempt

!

interface Vlan50

description NB-zone5-6509

ip address 10.20.50.1 255.255.255.0

ip helper-address 10.20.40.48

no ip redirects

no logging event link-status

standby 50 ip 10.20.50.3

standby 50 priority 110

standby 50 preempt


Switch#sh standby brief

P indicates configured to preempt.

|

Interface Grp Pri P State Active Standby Virtual IP

Vl20 20 110 P Init unknown unknown 10.20.20.3

Vl40 40 110 P Init unknown unknown 10.20.40.3

Vl50 50 110 P Init unknown unknown 10.20.50.3

Switch#

Switch#sh standby

Vlan20 - Group 20

State is Init (interface down)

Virtual IP address is 10.20.20.3

Active virtual MAC address is unknown

Local virtual MAC address is 0000.0c07.ac14 (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 110 (configured 110)

Group name is "hsrp-Vl20-20" (default)

Vlan40 - Group 40

State is Init (interface down)

Virtual IP address is 10.20.40.3

Active virtual MAC address is unknown

Local virtual MAC address is 0000.0c07.ac28 (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 110 (configured 110)

Group name is "hsrp-Vl40-40" (default)

Vlan50 - Group 50

State is Init (interface down)

Virtual IP address is 10.20.50.3

Active virtual MAC address is unknown

Local virtual MAC address is 0000.0c07.ac32 (v1 default)

Hello time 3 sec, hold time 10 sec

Preemption enabled

Active router is unknown

Standby router is unknown

Priority 110 (configured 110)

Group name is "hsrp-Vl50-50" (default)

Switch#



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
xcz504d1114 Mon, 07/13/2009 - 10:08
User Badges:
  • Bronze, 100 points or more

What's the other router/ L3 switch configuration look like?


It's in the INIT state because it's not talking to any other device that is participating in HSRP for those subnets.


Craig

agiaccotto Mon, 07/13/2009 - 10:56
User Badges:

at this point I don't have another side (L3-Switch), but I shouldn't need one for now because this should become the active switch, right ?

xcz504d1114 Mon, 07/13/2009 - 11:03
User Badges:
  • Bronze, 100 points or more

Well that's why it is in an INIT state :)


Yes it will be th active one, it will respond to both the x.x.x.1 and x.x.x.3 addresses.


Just so you are aware, when you get another HSRP client, the vitual IP is set to the x.x.x.3 IP, so all of your clients should be using that as the default gateway, if you point them to the x.x.x.1 address, then you wont have redundancy.


HTH,

Craig

agiaccotto Mon, 07/13/2009 - 11:18
User Badges:

Yes, I have 20 VLAN HSRP between our redundant 6513-L3. When I setup a new Interface Vlan xx on just one 6513-L3 switch it goes from INIT all the way to ACTIVE, even without an HSRP client. The 3550-L3 switch is not behaving the same way, it seems to be stuck in INIT state and NOT doing Learn, Listen, Speak, ACTIVE

xcz504d1114 Mon, 07/13/2009 - 11:27
User Badges:
  • Bronze, 100 points or more

Do a "show ip int brief" on your switch, I bet the VLAN's are in an up/down state.


Craig

agiaccotto Mon, 07/13/2009 - 11:58
User Badges:

yes, the VLAN interfaces are up/down. I can get them to become ACTIVE by connecting the second switch, but then where is the redundancy. If I power off one of the switches shouldn't the VLAN interfaces on the primary switch stay up/up and therefore the HSRP remain ACTIVE ?

iyde Sat, 07/18/2009 - 08:23
User Badges:
  • Silver, 250 points or more

You need a physical port (access or trunk with the VLAN in question alloved and active) enabled and in UP state in order to have the SVI (= VLAN interface) to be in UP state.

HTH.

Actions

This Discussion