DID dial-plan conflict

Unanswered Question
Jul 13th, 2009

I have a location who's DID numbers are 9600-9699 there extension numbers on there phones are 5600-5699. The telco is pulsing in 3 digits. I am wanting to do a translation rule to take the 3 digits pulsing in from the telco and ring the 5XXX extension number in CUCM. I am wanting to do this in there 2811 router so that it will work even in SRST. I am new to translations so please be clear.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
CHRIS CHARLEBOIS Mon, 07/13/2009 - 12:19

Here ya go...

!

voice translation-rule 1

rule 1 /*/ /5/

!

voice translation-profile prefix5

translate called 1

!

The apply 'translation-profile incoming prefix5' to your inbound call leg dial-peer.

Chris

chrisdaniels Tue, 07/14/2009 - 05:54

Thanks, I tried this and got the follow message.

mideastrtr01(cfg-translation-rule)#rule 1 /*/ /5/

% ?+* follows nothing ^

% Invalid input detected at '^' marker.

Looks like it will not take the /*/.

Any ideals?

chris

Adrian Saavedra Tue, 07/14/2009 - 06:04

Hi,

I believe that rule will not prefix 5 to your 3 digits from telco.

You need: rule 1 // /5/

Try that and let us know.

Best regards,

- Adrián.

pcameron Tue, 07/14/2009 - 06:05

Use this syntax -

!

voice translation-rule 1

rule 1 /^\(.*\)/ /5\1/

!

this will match on any lenght string , and it will prefix '5' to the front of it -

UC520-120#test voice translation-rule 1 123

Matched with rule 1

Original number: 123 Translated number: 5123

Original number type: none Translated number type: none

Original number plan: none Translated number plan: none

UC520-120#

chrisdaniels Tue, 07/14/2009 - 07:03

Thanks, that is working in the router now, however it is still not ringing my phone with the extension 5650, when I dial the DID XXXXXX9650.

Here is my dial-peer do I have something wrong?

dial-peer voice 209 voip

description Local dial-peer for destination-pattern 65. to extensions 651 -

translation-profile incoming prefix5

destination-pattern 65.

progress_ind setup enable 3

voice-class codec 1

voice-class h323 1

session target ipv4:xxx.xx.xxx.xx

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad

Thanks

Chris

CHRIS CHARLEBOIS Tue, 07/14/2009 - 08:17

I think you have the translation-pattern on the wrong dial-peer. This looks to be the outbound voip dialpeer. You want to put that translation pattern on the inbound pots dialpeer.

The way it's setup here, it will prepend a 5 to all calls dialed out from the CCM.

And then, yes, you would need to add a 5 to the destination pattern on the voip dialpeer.

chrisdaniels Tue, 07/14/2009 - 08:52

I may be wrong but I thought Pots dial peers are outbound from the router and voip are inbound. That is the way I am using them in my config.

My pots peers point to local lines on an FXO that allows the branch to dial out local.

Correct me if I am looking at this wrong.

Thanks

Chris

CHRIS CHARLEBOIS Tue, 07/14/2009 - 09:03

Every call through a voice gateway has two call legs and uses two dial-peers.

Calls from the PSTN to the VOIP system use an inbound POTS dial-peer and an outbound VOIP dial-peer, whereas calls from the VOIP system to the PSTN use an inbound VOIP dial-peer and an outbound POTS dial-peer.

In most cases, unless you intentionally create a dedicated inbound dial-peer, the same dial-peer you configure for outbound is also used for inbound in the opposite direction.

So where are these calls entering the router from the PSTN?

Adrian Saavedra Tue, 07/14/2009 - 09:13

Hi Chris,

I don't know if you already have this documents, but if not, this could help understanding dial peers (that sometimes at beginning is a bit confusing).

Understanding Inbound and Outbound Dial Peers Matching on IOS Platforms:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml

Configuring Dial Plans, Dial Peers, and Digit Manipulation:

http://www.cisco.com/en/US/docs/ios/12_2/voice/configuration/guide/vvfpeers.html

Hope it helps.

Best regards,

- Adrián.

chrisdaniels Tue, 07/14/2009 - 09:58

Thanks for the information, I will take a look at it.

I was able to get this working. Each post added a little more insight to the issue.

In the end I was able to add the following statement to my VOIP dial peer.

translation-profile outgoing prefix5

This seemed to work.

Thanks 5 points to all.

Chris

Actions

This Discussion