UC500 SIP endpoint

Unanswered Question
Jul 13th, 2009
User Badges:

Hi there,


I'm trying to have our UC500 function as the SIP endpoint for our local SIP provider (www.xs4all.nl)


What I know is:

  Username

  Password

  SIP Server: sip.xs4all.nl

  Proxy: sip.xs4all.nl

  Proxy port: 5060

  Expire time: 3600


Codecs:

  G.711a

  G.711u

  G.729


DTMF

  inband for G711

  RFC2833 and inband for G729

  RFC2833 for g729


I am trying to figure out where to fill out what in the CCA to be able to use our two SIP numbers,

both for outgoing and incoming calls. So, each number has its own username + password.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
eljakimit Mon, 07/13/2009 - 12:49
User Badges:

Thank you for your quick response! I did indeed find that screen.


Now, what are the digest user credentials? What do I fill out there?


Is there a way to specify different SIP servers? (ie, we'd like to specify one for all international calls and one (xs4all) for all domestic calls).


Eljakim

Maulik Shah Thu, 11/05/2009 - 09:12
User Badges:
  • Silver, 250 points or more

Not sure if this would help but attached is an XML file that coversthe portions you had in the first post (codec is G729, DTMF is RFC2833, fax is upspeed to G711, along with options to add usernames / passwords for each DID under credentials) - check doc below on how to add this XML file to CCA (you may need to first set SIP Trunk to None, hit Apply and then follow the steps)


https://www.myciscocommunity.com/docs/DOC-9168


With regards to 2 SIP trunk providers - CCA does not support this today. You could route calls via CLI to different SPs however registration to multiple SPs is something that is on our roadmap for early next year.

Maulik Shah Fri, 11/06/2009 - 09:51
User Badges:
  • Silver, 250 points or more

Thanks for putting this together - I added  reference on the main SIP trunk page


https://supportforums.cisco.com/docs/DOC-9830


I did not follow the password issue you brought up - FYI the password is encrypted in CLI so the length will not match the real password but it should work from a SIP perspective. Why would you not enter the right password initially?

martinipenburg Thu, 09/03/2009 - 08:24
User Badges:

Hi,


did you manage to get this connection working as were are also configuring sip with xs4all using the uc520.


thanks


Martin

eljakimit Thu, 09/03/2009 - 08:46
User Badges:

Hi Martin,


no, we haven't gotten it to work yet. If you have any great ideas or insights, please post them here!


Eljakim

martinipenburg Wed, 09/09/2009 - 03:42
User Badges:

we changed over to a different sip provider (virtualpbx.nl) and now inbound and outbound sip calls are possible. we are now busy testing.

scd2zaken Thu, 11/05/2009 - 07:49
User Badges:

Dear EljakImit,


It is hard to get XS4ALL working, at this moment I use the latest CCA and IOS(ua) version.
You have to fill in the standard sip server information in the SIP panel.


After the basic installation make a inbound link.
After this check if you can call outside.
If not check the next statement in de config file:


voice source-group CCA_SIP_SOURCE_GROUP
In this group their woill be a line:
access-list 2
translation-profile incoming SIP_Incoming
Remove these two lines (no access-list 2)

And test the outgoing connection.
This is still a bug in the CCA software versus the CLI

For incoming connections we are still tracing the correct problem ..

P.S. XS4ALL will use SIP/VOIP ISP services from a firm in France .. and we do not know how
compatible these are with Cisco hard/software.

If we find more information, I will leave it here,

Regards,

Eric Oosterbaan
Engineer - The netherlands
www.uc500.info
eljakimit Thu, 11/05/2009 - 08:47
User Badges:

Hi Eric,


thank you for your information! I'll try things out next week, and I'll keep you posted.


Eljakim

scd2zaken Sat, 11/07/2009 - 08:18
User Badges:

I've found the weird ' password'  problem after debug the SIP communication.
It said ' Name or Password'  wrong.
I changed the password by CLI, and the connection was ' up and running '.


An another thing who is not stable .. after power down (full restart) of the UC500 the SIP registration wil not become active.

Via CLI you can make the connection active:


First check after the power reboot:

!

#sh sip register status

!

you will see:

Line          peer   expires  registered   P-asso.

============  =============  ============  ===========

085xxxxxxx              -1          0              no
!

But you CAN make a call outside !


Via the CLI go to the part in the config file: sip-ua
Change the line: registrar dns:sip.xs4all.nl expires 3600 in ' no registrar'

Change the line again back in 'registrar dns:sip.xs4all.nl expires 3600'

And write the config. ( with write command)


Now check the register status again, and you CAN receive AND send phone calls ! .... Weird isn't it !
Next shown the active registered:

Line          peer           expires(sec)  registered   P-Associated-URI
============  =============  ============  =========== 
085xxxxxxxx                       20011       0             yes


BUT !! Their is NO discounting of the expired(seconds) ... and it seems that after 1 hour the connection will be lost !


!! CHECK after 1 hour:

At the check ' sh sip register status'  it seems te be Ok, but it isn't.
The UC500 can't receive any phone-call after 1 hour.

I will change the register time (update time) to a shorter interval:


voice service voip
!

sip
  rel1xx disable
  registrar server expires max 3600 min 3600
  localhost dns:sip.xs4all.nl
  no update-callerid


To:

registrar server expires max 1300 min 300


And:  registrar dns:sip.xs4all.nl expires 3600 to 7200 seconds !


P.S. I updated the Cisco 876W router with the latest IOS, to have the possibility to check the SIP traffic from WAN ..

Maulik Shah Sun, 11/08/2009 - 10:40
User Badges:
  • Silver, 250 points or more

Need to check the "deb ccsip message" for a registration sequence - seems like there is something incorrect in the Registration timer which results in the expires always being 0.


I cannot see why username / password would ever change after configuration unless the hash generated is incorrect because of some other parameter - have not had that issue in all the deployments thus far. I do not think the upstream WAN router (which does NAT I presume) would affect the username / password. Again a debug for when this issue occurs would be great.