RMEDbEngine doesn't start when migrating data from LMS 2.6 to LMS 3.1

Answered Question
Jul 14th, 2009


we had a LMS 2.6 installed in a Windows server and we are trying to migrate data to a LMS 3.1 (in a Windows server as well).

We are following the migration guide, so we launch wrapper.pl, take the backup to the other server and execute the restorebackup.pl.

When it finishes, it says everything has gone fine but after starting Daemon Manager, RMEDbEngine doesn't start, neither manually.

Please find attached an error we can see in restorebackup.log.

We have tried several times (even with different backups) but we always obtain the same error message in restorebackup.log and RNMEDbEngine never starts.

In rmeng folder, rmeng.db and filebackup.tar are 2 Gb.

I have seen in another thread that it's interesting to check the command:

D:\CSCOpx\bin\perl D:\CSCOpx\objects\db\conf\configureDb.pl action=validate dsn=rmeng

Please find attached the output in configureDb.rar

Can anyone please help me?


I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 3 months ago

The database will be fine. Once you restart Daemon Manager, LMS 2.6 will continue to operate just as it did before.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Joe Clarke Tue, 07/14/2009 - 08:40

The most obvious problem I see is that the server is localized for Spanish instead of US English. It could also be that the RME 4.0 database or its transaction log are damaged in some way. On the LMS 2.6 server, shutdown Daemon Manager, then delete NMSROOT\databases\rmeng\rmeng.log if it exists. Then run:

NMSROOT\objects\db\win32\dbsrv9 -f NMSROOT\databases\rmeng\rmeng.db

Then take a new wrapper.pl backup of the LMS 2.6 server. Then compress the backup directory, and transfer it to the LMS 3.1 server. Then try the migration again.

cmartinvalle Tue, 07/14/2009 - 09:16

I don't know why the messages appear in Spanish because the server is installed in English and the regional settings are configured in US English, only the location is configured in Spanish, but I think it's not important, isn't it? No warnings appeared during the installation.

What does that command "dbsrv9" do? Does it delete any data?

Joe Clarke Tue, 07/14/2009 - 09:38

The localization can cause problems, and is a difference from what we run and test with internally.

The dbsrv9 -f command forces the database to a closed state without the use of a transaction log. It is used for transaction log recovery. It does not delete any data already committed to the database.

cmartinvalle Tue, 07/14/2009 - 23:00

And after execute it, will the database accept more records or will it enter in a paused state where no more data will be accepted?

I need to know this because we have to use the old LMS 2.6 until we will be able to migrate tha data succesfully.

Correct Answer
Joe Clarke Wed, 07/15/2009 - 08:34

The database will be fine. Once you restart Daemon Manager, LMS 2.6 will continue to operate just as it did before.


This Discussion