BGP Configuration Help

Unanswered Question
Jul 16th, 2009
User Badges:

Here is the customers L3 Switch - What am I missing here? Let me know if more info is needed.


interface GigabitEthernet0/3

ip address Other Provider IP B.B.B.170 255.255.255.252 secondary

duplex auto

speed auto

media-type rj45

negotiation auto

!

router bgp ##AS##

no synchronization

bgp log-neighbor-changes

network x.x.x.x

neighbor B.B.B.169 remote-as ##B's AS##

neighbor B.B.B.169 description Primelink

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 B.B.B.169

ip route 0.0.0.0 255.255.255.255 10.1.1.0

no ip http server

no ip http secure-server

ip as-path access-list 1 permit ^##B'sAS##$

!

!

!

logging alarm informational

access-list 10 permit X.X.X.X 0.0.255.255

access-list 101 permit tcp any any

access-list 101 permit udp any any

access-list 101 permit ip any any


route-map AS-B'sAS-INCOMING permit 10

match as-path 1


route-map AS-B'sAS-OUTGOING permit 10

match ip address 10

!

route-map AS-15320-OUTGOING permit 20

match ip address 20

!

!

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jerry Ye Thu, 07/16/2009 - 06:40
User Badges:
  • Cisco Employee,

Hi Gabrielle,


Any special reason you make the interface IP address secondary? Also, what are you trying to accomplish with this static route?


ip route 0.0.0.0 255.255.255.255 10.1.1.0


I don't see your as-path access-list and route-map applied inside the BGP process.


Regards,

jerry



cozyk1515 Thu, 07/16/2009 - 07:41
User Badges:

I am trying to help this customer get this up and running. I have another static that was for testing on the interface that is why it is secondary. Also, I am not sure why he has this route of 10.1.1.0.



Jerry Ye Thu, 07/16/2009 - 07:45
User Badges:
  • Cisco Employee,

Hi Gabrielle,


You might have problem with the BGP peering section since the BGP peering will use the primary IP address. Beside that, this is the only issue I am seeing so far.


HTH,

jerry

Actions

This Discussion