WRVS4400N - trying to VPN from behind router

Unanswered Question
Jul 16th, 2009

I have a WRVS4400N, which for the most part performs fine except for this.  I have a PPTP VPN connection setup on my home computer and laptop to our office.  Its the simple MS VPN to an ISA server back in the office.

When i try to connect via the VPN from behind the router, it never connects, simply times out.  I have tried disabling the firewall, Block WAN requests, everything that i can find to disable, and still no joy.

If i remove the WRVS4400N router and connect directly to the internet, i connect just fine, so its definately the Cisco WRVS4400N causing the issues.  Everything i read tells me it is some how blocking GRE, yet i am not sure how even with the firewall disabled.

Cisco, can you help?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Carr Fri, 07/17/2009 - 07:51

Aaron, try going into the port forwarding tab and forward port 1723 and port 47.  Port 1723 is the pptp port using tcp and port 47 is the gre port.  Give that a shot and see what you got.  By the way what firmware version do you have?  And what version is your wrvs4400n.  Thank You.

aaron.robinson Fri, 07/17/2009 - 21:33

Thanks for the quick reply.  First, i have firmware version V1.1.03, and router version is 1.1.

I have tried single port forwarding both 1723 and 47, and i have also tried port triggering, and both give the same result.

Any suggestions on what i should try next?

Thanks again for the reply.


Te-Kai Liu Sun, 07/19/2009 - 08:30

Can you provide a packet capture of the PPTP session seen by the PPTP client when it's behind WRVS4400N?

Alternatively you could try to contact the tech support to see if they can duplicate the issue. This will speed up the issue resolution if there is indeed a defect in the firmware.

David Carr Mon, 07/20/2009 - 08:33

Aaron, how about upgrading to the latest version of firmware as a first step and see if that works.  Version 1.1.13 from the cisco.com website.  Try that and keep us posted.

aaron.robinson Mon, 07/20/2009 - 18:19

I was able to upgrade the router to firmware version 1.1.13 as you suggested, but with no luck.  Still the same results.  I am going to post a network capture as the previous post suggests.

alex.wright Wed, 07/21/2010 - 17:05

Sorry for bumping a year old thread, but I am having the same issue  with this router with a very similar setup, and I couldn't find a solution anywhere. Does  anyone know what would be causing this?

Just to note, I have PPTP passthrough enabled and am forwarding both TCP and UDP 1723  to the IP of the VPN server. If i set the IP as the DMZ host, I can  connect just fine. I don't want to run that machine as the DMZ host  permanantly, however.


I have the exact same problem. I just upgraded from a WRT300N router which works fine with PPTP to a WRVS4400N router. I enable TCP port 1723 on the WRVS4400N and set all 3 tunnels to passthrough. I noticed that PPTP works fine until I send a PPP LCP Configuration Request to the Windows 2003 server sitting behind the router. Apparently the 2003 server does not receive the request; at least my PPTP does not receive a response. It almost looks like IP Port 47 (GRE) is not open and the packets are not being forwarded to the server.

Any idea how to fix the problem ?

I haven't yet tried setting my Windows 2003 server in the DMZ. I susptect that might fix the problem, but that's very insecure.

Any pointers are appreciated.


Dalia Geller

pierre-luc.dube Tue, 04/17/2012 - 07:36

After 1 years anyone have a solution?

i have same probleme with my WRVS4400N and my SBS2011.

Port forwarding 1723 TCP/UDP

Activate PPTP PassThrough:

Local VPN work fines but not extern. On wireshark, the connection block on LCFconfiguration Request ( it's on GRE47)

Help me


This Discussion