rstp port role, states

Answered Question
Jul 16th, 2009

Hi every body!

RStp has following port roles:

root port

designated port

alternate port

back up port

Let focus on alternate port role.

My book says a switch receiving the 2nd best bpdu on a port, will consider that port as alternate port.

So we have a switch sw1 with three ports connected to switched networks in s uch a manner that f0/1 becomes a root port because it receives the best bpdu. The other two ports f0/2,f0/3connected to same neighboring switch, are also receiving bpdu but f0/2 receives the 2nd best bpdu( f0/2 has lower port id), so based on the excerpt from my book, f0/2 will be considered as alternate port. What about f0/3 ? what role it will be assigned? it can not be alternate port as f0/2 has already been choosen as alternate port?

=========================

Back up port:

That is what the book says"Backup ports are ports that received more useful bpdu from the same switch they are on."

let say sw1 and sw2 has already determined their root port and alternate ports. These two switches are not connected directly.

Let say we connect these two switches via hub;

sw1's f0/1.f0/2 are connected to hub

sw2 f0/3 is connected to same hub as well.

Let say f0/3 is designated port. What role will be assigned to f0/1 and f0/2 of sw1? they cannot be back up . Based on the defination above in the execrpt, f0/2 and f0/3 of sw1 can not be back up . So if they are not back up then what are they?

Thanks a lot!

I have this problem too.
0 votes
Correct Answer by Francois Tallet about 7 years 4 months ago

Yes, they won't be backup. If the information in the BPDU received does not beat the one of the current root port, they'll both be alternate.

Only if f0/1 (resp f0/2) is designated for this LAN will f0/2 (resp f0/1) be backup.

Regards,

Francois

Correct Answer by Jerry Ye about 7 years 4 months ago

Hi,

The following link has very good explaination of the RSTP port role.

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_white_paper09186a0080094cfa.shtml#roles

Regards,

jerry

Correct Answer by Francois Tallet about 7 years 4 months ago

A bridge X puts a redundant port in backup role when it receives a BPDU from itself (i.e. the designated port for this LAN is on bridge X).

An alternate port on bridge X is blocked because it receives BPDUs from a designated port on bridge Y.

Regards,

Francois

Correct Answer by Jerry Ye about 7 years 4 months ago

Hi,

Assuming f0/3 will be configured the same as the other two (2) port. It will be assigned as alternate port also.

Just a quick test from my lab:

SW1 - STP ROOT -

!

spanning-tree mode rapid-pvst

spanning-tree vlan 1-1004 priority 24576

!

vlan 10

!

interface GigabitEthernet0/13

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/14

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/15

switchport trunk encapsulation dot1q

switchport mode trunk

!

SW2 -

!

vlan 10

!

spanning-tree mode rapid-pvst

!

interface GigabitEthernet0/13

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/14

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/15

switchport trunk encapsulation dot1q

switchport mode trunk

!

show spanning-tree vlan 10

SW1 -

VLAN0010

Spanning tree enabled protocol rstp

Root ID Priority 24586

Address 001b.d418.eb80

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24586 (priority 24576 sys-id-ext 10)

Address 001b.d418.eb80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi0/13 Desg FWD 4 128.13 P2p

Gi0/14 Desg FWD 4 128.14 P2p

Gi0/15 Desg FWD 4 128.15 P2p

SW2 -

VLAN0010

Spanning tree enabled protocol rstp

Root ID Priority 24586

Address 001b.d418.eb80

Cost 4

Port 13 (GigabitEthernet0/13)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)

Address 001b.d418.f200

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi0/13 Root FWD 4 128.13 P2p

Gi0/14 Altn BLK 4 128.14 P2p

Gi0/15 Altn BLK 4 128.15 P2p

HTH,

jerry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Correct Answer
Jerry Ye Thu, 07/16/2009 - 14:56

Hi,

Assuming f0/3 will be configured the same as the other two (2) port. It will be assigned as alternate port also.

Just a quick test from my lab:

SW1 - STP ROOT -

!

spanning-tree mode rapid-pvst

spanning-tree vlan 1-1004 priority 24576

!

vlan 10

!

interface GigabitEthernet0/13

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/14

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/15

switchport trunk encapsulation dot1q

switchport mode trunk

!

SW2 -

!

vlan 10

!

spanning-tree mode rapid-pvst

!

interface GigabitEthernet0/13

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/14

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/15

switchport trunk encapsulation dot1q

switchport mode trunk

!

show spanning-tree vlan 10

SW1 -

VLAN0010

Spanning tree enabled protocol rstp

Root ID Priority 24586

Address 001b.d418.eb80

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24586 (priority 24576 sys-id-ext 10)

Address 001b.d418.eb80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi0/13 Desg FWD 4 128.13 P2p

Gi0/14 Desg FWD 4 128.14 P2p

Gi0/15 Desg FWD 4 128.15 P2p

SW2 -

VLAN0010

Spanning tree enabled protocol rstp

Root ID Priority 24586

Address 001b.d418.eb80

Cost 4

Port 13 (GigabitEthernet0/13)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)

Address 001b.d418.f200

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi0/13 Root FWD 4 128.13 P2p

Gi0/14 Altn BLK 4 128.14 P2p

Gi0/15 Altn BLK 4 128.15 P2p

HTH,

jerry

sarahr202 Thu, 07/16/2009 - 15:06

Thanks Jerry!

Could you please explain back up port question that is if you have time ?

Correct Answer
Francois Tallet Thu, 07/16/2009 - 15:13

A bridge X puts a redundant port in backup role when it receives a BPDU from itself (i.e. the designated port for this LAN is on bridge X).

An alternate port on bridge X is blocked because it receives BPDUs from a designated port on bridge Y.

Regards,

Francois

sarahr202 Thu, 07/16/2009 - 16:00

Thanks Francois!

Assume the switch has already determined its root port f0/4, and alternate port f0/5.

How about if the same switch receives bpdu on its two ports f0/1,f0/2 connected to same segment from designated port on a different switch?

they(f0/1,f0/2) can not be assigned back up role as these ports are receiving bpdu from different switch?

Thanks a lot!

Thanks a lot!

Correct Answer
Francois Tallet Thu, 07/16/2009 - 22:45

Yes, they won't be backup. If the information in the BPDU received does not beat the one of the current root port, they'll both be alternate.

Only if f0/1 (resp f0/2) is designated for this LAN will f0/2 (resp f0/1) be backup.

Regards,

Francois

Actions

This Discussion