SPA2102 line 1 picks up both line 1 and line 2

Unanswered Question
Jul 16th, 2009
User Badges:

I have an SPA2102-R which is from the broke SunRocket.  Fortunetly I was able to unlock the device.


I am able to register with both SipGate One (on line 1) and Gizmo5 (on line 2).  Line 1 has SIP port 5061 and Line 2 has SIP port 5060. Line 2 behave normally (I can receive from and make calls to other Gizmo5 users).  When I disable Line 2, Line 1 behave normally (can receive and making phone calls).  When both Line 1 and Line 2 are enabled, Line 2 still behave normally but Line 1 is funny:


(I only plug in a regular phone in line 1, line 2 has nothing plug in)


A. When I call either line 1 or line 2 from other phone, line 1 will ring, and
B. No matter which line I try to call from other phone, line 1 rings, and when I anser line 1 (pick up the phone plugged in line 1), I hear both the other side and a dial tone (from the line I am not calling, I assume).


Even if I disable line 1, line 1 still works as if it were line 2.


Can anyone help me?  Thanks.


XW

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Patrick Born Fri, 07/17/2009 - 15:58
User Badges:
  • Cisco Employee,

Hi XW,


Consider posting the device's config so the community can take a look to see if anything obvious is  incorrectly configured.


Regards,



Patrick

----------

spauser_jd Fri, 07/17/2009 - 16:21
User Badges:

Hi Patrick,


Thanks in advance.  Attached are the pictures of configuration:


pic1 and pic1a : Line 1 tab

pic2 and pic2a : Line 2 tab

pic3: SIP tab


I did not touch anything else.  My SPA2102 is directly plugged into cable modem so I believe there isn't any portforwarding issue.


Thanks!


XW

spauser_jd Fri, 07/17/2009 - 18:48
User Badges:

Sorry, I am not able to download slogsrv.exe (Forbidden File or Application).


XW

spauser_jd Fri, 07/17/2009 - 20:31
User Badges:

Hi Patrick,


I've got "Kiwi Syslog Server" to work and it is recording all the message from the SPA2102-r.  See attached.


Thanks!


XW


P.S.  This time, I've put both my PC and the SPA2102-r behind a router TrendNet TEW-452BRP.  I do get a dial tone when I pick up the phone, either line 1 (SIPGATE) or line 2 (GIZMO5 SIPPHONE.COM).  I can dial out through line 2 to other Gizmo acount and make conversations.  Somehow I can not receive calls, may be because of the router (I did not do any ports forwarding).  Calls from outside directly goes to voice mail.

spauser_jd Sun, 07/19/2009 - 11:55
User Badges:

I've figured out why.


"Line1 / Line2 => Phone Port Line 1" is afeature of SPA2102.


I have a 2 line phone and a 4 wire phone cord so it will pick up both Line1 and Line2 if connected to SPA2102's phone port line 1.  If I use a 2 wire phone cord and a one line phone, those 2 will not mix.


A 2 line analog phone matches perfectly with SPA2102.  With one 4 wire cord, the phone will ring when either line 1 or line 2 receive a call, and you got to select which line you want to pick up.


Thanks for spending time on the issue!


XW

Patrick Born Mon, 07/20/2009 - 15:46
User Badges:
  • Cisco Employee,

Hi XW,


Great troubleshooting. Thanks for sharing the solution with the community.


Regards,



Patrick

----------

Actions

This Discussion

Related Content