RSPAN traffic in Linux

Unanswered Question

I am having difficulties with getting RSPAN traffic in Linux over my trunk link.


Here's the setup .


[PC1]---[Gi0/1--CoreSw--Gi0/2]---802.1q trunk---[PC2_Linux]



CoreSW - Cisco C3560E version IOS 12.2(35r)SE

PC2_Linux - Linux PC with a VLAN is working properly



Current configuration of Gi0/1:

interface GigabitEthernet0/1

description MVTS1 port 1

switchport access vlan 21

switchport mode access

end


Current configuration of Gi0/2:

interface GigabitEthernet0/2

description Link to XEN01/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 60,66,98,208

switchport mode trunk

channel-protocol lacp

channel-group 1 mode passive

end


Current configuration of VLAN 98:

vlan 98

remote-span

end


Current configuration of monitor sessions:

monitor session 2 source interface Gi0/1

monitor session 2 destination remote vlan 98



I'm trying to view a traffic from Gi0/1 on PC2. I don`t see it.

Can who help me and tell where the error?


Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
umedryk Thu, 07/23/2009 - 14:44
User Badges:
  • Bronze, 100 points or more

A Catalyst 2950 switch may not RSPAN traffic correctly. This is due to an ASIC limitation specific to the 2950 platform.

Actions

This Discussion