ASA SIP inspection process is not working ?

Answered Question
Jul 17th, 2009
User Badges:

Hi I have an issue with Cisco ASA 5520, The summary is below!


Packet # 1 on inside capture the Call-ID was: Call-ID: 2a54f680-

[email protected]


Packet # 1 on outside interface the Call-ID was: Call-ID: 2a54f680-

[email protected] --- this bcz of the inspection.


Packet # 2 on outside capture the Call-ID was: Call-ID: 2a54f680-

[email protected]


Packet # 2 on inside capture the Call-ID stay: Call-ID: 2a54f680-

[email protected] --- this is the problem.


(This suppose to be Call-ID: [email protected])



The inspection should change the Call-ID for the incoming packet as it

did with the outgoing packet. Whenever, the CM receive the trying

message with different Call-ID it considered as new session and it keep

sending invitation messages for the SIP provider.


NAT is enabled.


How to fix the above problem ?

Any help will be appreciated.


Thanks

Correct Answer by drolemc about 7 years 9 months ago

Verify any Xlate entries on SIP server. You might also want to include inspect SIP in your global policy. There are also lots of bugs in 8.0(3) regarding SIP handling

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Loading.
Correct Answer
drolemc Fri, 07/24/2009 - 10:03
User Badges:
  • Silver, 250 points or more

Verify any Xlate entries on SIP server. You might also want to include inspect SIP in your global policy. There are also lots of bugs in 8.0(3) regarding SIP handling

lusandi Thu, 07/14/2011 - 08:53
User Badges:
  • Bronze, 100 points or more

Can you post the ASA configuration?


Regards,


Luis Sandi


.:|:.:|:.


P.S Please mark this question as answered if it has been resolved. Do rate helpful posts.

Actions

This Discussion