ip camera macs disappearing on switch ports

Unanswered Question
Jul 17th, 2009

Hi All:

i'm having an issue with some ip cameras we have deployed on our network. it seems that every so often we get a few that go "offline" and can no longer communicate with them. the switch (3550-24PWR) interface shows a physical connection, but the cameras mac does not show when issuing the sh mac-address-table interface command. if i restart the camera, all is well. is there any reason a mac would "disappear" from an interface. i do not have port-security enabled. thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Fri, 07/17/2009 - 08:15

Brandon

"is there any reason a mac would "disappear" from an interface. i do not have port-security enabled."

Yes, if the switch times out the mac-address entry because of no communication between the ip camera and the rest of the network.

When you restart the camera it probably has to communicate with the network and so the switch has the mac-address again.

However if you pinged the IP address of the camera this should reenter the mac-address into the CAM table on the switch.

Jon

bmarms Fri, 07/17/2009 - 10:00

"However if you pinged the IP address of the camera this should reenter the mac-address into the CAM table on the switch."

i thought so as well, but that does not work. i have to reboot the cameras. is there anything else that can be done? can i change the CAM timeout value for the ip camera MACs?

Actions

This Discussion