"ghost devices" - can't find place to delete

Unanswered Question
Jul 17th, 2009

I have a number of devices that were discovered at installation. Nothing was done w/ Ciscoworks for a longer period of time. All IPs on all devices have changed. I attempted to clean out the database and rediscover, I end up with devices that show in CS- DCR and AAA Information as "Devices Not Configured in ACS". Which they shouldn't be. I've tried Device Center - says the device is unavailable, I've tried CLI, can't find the devices, etc. Has anyone run into this? Is there a way to get rid of them?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 07/17/2009 - 12:04

You have to temporarily break ACS integration, then you will be able to see those devices in LMS. To do this, run the following script from the server's command line:


NMSROOT/bin/perl NMSROOT/bin/ResetLoginModule.pl

Rick Meier Fri, 07/17/2009 - 12:07

I'm running on windows, is the same script available? Does this reset the ACS config in server setup?

Joe Clarke Fri, 07/17/2009 - 12:17

Yes, it's the same script. No, the ACS config is retained. It's just turned off. You can easily re-enable integration from the GUI once you have cleaned up DCR.

Rick Meier Fri, 07/17/2009 - 13:04

This did work. I was able to delete the devices. When I went into server setup to reset ACS, I had to re-enter all the server info. it was all cleaned out with the reset. Also, the daemon manager has to be stopped to run the perl script, then restarted.

Joe Clarke Fri, 07/17/2009 - 15:54

Yes, the Daemon Manager has to be stopped, but the ACS integration information should not have been lost. All this script does is delete the file which contains the JAAS login module name, and sets the AdminMode to CMF in regdaemon.xml. The remaining ACS integration options in regdaemon.xml are not touched. Something else must have caused these parameters to be deleted.

Actions

This Discussion