cisco 2811 wic 1T:Serial0/0/0 is up, line protocol is down : how to resolve

Unanswered Question
Jul 20th, 2009
User Badges:

I need to configure Cisco 2811 serial wic 1T but it doesn't work : Serial0/0/0 is up, line protocol is down

See the architecture in attachments

I don't know with type of equipment is used on remote side

See below the configuration of serial on remote site(the ISP have send it)


Serial4/7 is up, line protocol is up

Hardware is M8T-V.35

Description: CUS: ABCD

Internet address is 162.192.48.119/30

MTU 1500 bytes, BW 3584 Kbit, DLY 20000 usec,

reliability 247/255, txload 12/255, rxload 7/255

Encapsulation HDLC, crc 16, loopback not set

Keepalive set (10 sec)

Restart-Delay is 0 secs


See also the output command on my Cisco 2811 router in attachment

When I change the Cisco 2811 and use different router(not Cisco), it work

Please how can I solve this problem ?




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jerry Ye Mon, 07/20/2009 - 05:02
User Badges:
  • Cisco Employee,

Hi,


You can tried to put the following command to see if that fix the problem.


encapsulation ppp


Also, I see your have the following command


no ip route-cache cef

no ip route-cache


this will make the switch to use switch process the packets, and it can cause high CPU. You should consider to do


ip route-cache cef

ip route-cache


HTH,

jerry

Richard Burts Mon, 07/20/2009 - 05:27
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

cam


While I agree with Jerry that it is much better to use ip route-cache cef and ip route-cache, I do not believe that this is the fundamental problem.


In my experience there are several things that can cause line up line protocol down on serial interfaces. One of them is protocol mismatch (perhaps HFLC on one end and PPP on the other end). But if what is included in your post is accurate then both ends are using HDLC. Another thing that can cause this symptom is if one end is configured to use keepalives but the other end is configured with no keepalive. But it looks like both you and the provider are using keepalive.


Another thing that can cause the symptom is a problem with clocking. We can not tell from what is posted if it might be a problem with clocking. Perhaps if you would post the output of show controller we might have some useful information about this.


I also wonder if the problem might be a problem in connectivity. Can you verify that you are correctly connected?


As I look more closely at what you posted I notice that the output of show interface shows that Carrier Detect is down. I believe that this may also point to some connectivity problem.


While it is not part of the fundamental problem I would point out that there are problems in the addressing configured on your router. The interface configured on your serial interface does not match the address configured by the provider (check the first octet). Also the addresses on the Ethernet interfaces seems to be in the same subnet, which is not valid.


HTH


Rick

nicanor00 Mon, 07/20/2009 - 05:30
User Badges:

Thanks for your reply


Encapsulation PPP doesn't work


I forget one precision

When I configure encapsulation to HDLC, line protocol is up few second and then go back to line protocol down


When I use encapsulation PPP it doesn't work


Please I need help I am very disappointed



Jerry Ye Mon, 07/20/2009 - 05:34
User Badges:
  • Cisco Employee,

Hi cam,


I will agree with Rick to check your clocking, you can post the output of the show controller output.


Regards,

jerry

nicanor00 Mon, 07/20/2009 - 06:02
User Badges:

As I told you before,


I forget one precision

When I configure encapsulation to HDLC, line protocol is up few second and then go back to line protocol down


When I use encapsulation PPP it doesn't work


During the troubleshooting, I copied the show controller output(just the serial part)

You can see it in attachment


Now I am not near the equipment , but if you absolutely need the whole show controller output, I can go back and copy it


Thanks in advance for your help




Attachment: 
Jerry Ye Mon, 07/20/2009 - 06:25
User Badges:
  • Cisco Employee,

HDLC is tring to come up. Since it cannot come up at all, line protocol will be up for a few second and goes back down. This is normal behavior.


Your show controller output is fine.


HTH,

jerry

slmansfield Mon, 07/20/2009 - 08:12
User Badges:
  • Silver, 250 points or more

According to your picture you have a Comtech CDM-600 modem in front of the Cisco router. This modem has a fairly extensive set of software-configured options for the serial connection. It looks like the configuration on the modem is what should be matched up with the configuration on the Cisco router's serial interface.


Assuming your satellite provider supports the modem (as well as the non-Cisco router?), I'd see if the provider can assist you in resolving this.


http://www.satcomnow.com/satcom/pdf/mn-cdm600_r7.pdf


Here is other documentation on the Comtech website.


http://www.satcomresources.com/Comtech-CDM-600-PSK-Digital-Satellite-Modem

cisco steps Mon, 07/20/2009 - 08:21
User Badges:

make sure the PPP is configured on both side. what is your LCP indicate is it open , close, what stages that goes trough. you also need to chk the framing (ESF/B8ZS)


Hope this helps

fmjiang1966 Mon, 07/20/2009 - 08:33
User Badges:

Hi,


Please check your Serial0/0/0 IP address config:


On the SP side:

Internet address is 162.192.48.119/30


IP address for your S0/0/0:

160.192.50.120 255.255.255.252


They are not in the same subnet.


verify and correct, then test if it works.


Fuming


fmjiang1966 Mon, 07/20/2009 - 08:38
User Badges:

One more thing:


If your S0/0/0 address is:

160.192.50.120/30


Your default-route has problem:

ip route 0.0.0.0 0.0.0.0 160.192.48.119


You cann't reach gateway 160.192.48.119 because they are in different subnet.

nicanor00 Mon, 07/20/2009 - 10:33
User Badges:

I change the IP addrese but the problem is the same


interface FastEthernet0/0

description Connect To a

ip address 162.210.33.129 255.255.255.192

duplex auto

speed auto

!

interface FastEthernet0/1

description Connect To b

ip address 162.210.33.252 255.255.255.192

duplex auto

speed auto

!

interface Serial0/0/0

description To Internet

ip address 160.192.50.130 255.255.255.252

no ip route-cache cef

no ip route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 160.192.50.129

nicanor00 Mon, 07/20/2009 - 10:37
User Badges:

the serial wic 1T is connected opposite Comtech CRS 340 card

I made some research on this card.

See below the caracteristic of this card Comtech CRS 340 card


CRS-340 - EIA-422/-232, LVDS, G.703 Mixed Interface

(1) 25-pin 'D' type female connector

EIA-422/-530 DCE, V.35, SYNC EIA-232, LVDS

(1) 15-pin 'D' type female connector

G.703 Balanced (DDI, DDO, IDI, IDO)

(2) BNC type female connectors

G.703 Unbalanced, (DDI, IDO)



I use the (1) 25-pin 'D' on Comtech CRS 340 card



Do you think that the WIC 1T card should work opposite the Comtech CRS 340 card

fmjiang1966 Mon, 07/20/2009 - 11:02
User Badges:

Hi,


But your SP side address is:


Serial4/7 is up, line protocol is up

Hardware is M8T-V.35

Description: CUS: ABCD

Internet address is 162.192.48.119/30


If your SP side address is:

160.192.50.129/30


Then I guess it will work.


Fuming


fmjiang1966 Mon, 07/20/2009 - 11:46
User Badges:

Hi,


Your IP address and subnet has problems.


Serial4/7 is up, line protocol is up

Hardware is M8T-V.35

Description: CUS: ABCD

Internet address is 162.192.48.119/30


162.192.48.119/30 is broadcast address of subnet 162.192.48.116/30.


162.192.48.116/30 has two usable addresses:

162.192.48.117 and 118.


162.192.48.119/30 cannot be used as interface address.


Fuming




nicanor00 Mon, 07/20/2009 - 16:55
User Badges:

Sorry my ISP address is

160.192.50.129


the serial wic 1T is connected opposite Comtech CRS 340 card

I made some research on this card.

See below the caracteristic of this card Comtech CRS 340 card


CRS-340 - EIA-422/-232, LVDS, G.703 Mixed Interface

(1) 25-pin 'D' type female connector

EIA-422/-530 DCE, V.35, SYNC EIA-232, LVDS

(1) 15-pin 'D' type female connector

G.703 Balanced (DDI, DDO, IDI, IDO)

(2) BNC type female connectors

G.703 Unbalanced, (DDI, IDO)



I use the (1) 25-pin 'D' on Comtech CRS 340 card


Do you think that the WIC 1T card can work opposite the Comtech CRS 340 card

sachin_mon Thu, 10/14/2010 - 06:15
User Badges:

Hi,


Did you find any solution to this ? I am also having the same issue.


Please let me know. Thanks.


Rgds./Sack

paolo bevilacqua Thu, 10/14/2010 - 14:55
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Interface protocol down means circuit failure, complain to ISP.

Richard Burts Thu, 10/14/2010 - 21:05
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

While circuit problems are a major source of line protocol down, there are a number of other things that will also cause line protocol to be down. Some of the things that come to mind include:

- layer 2 protocol mismatch (HDLC on one end and PPP on the other).

- running a layer 2 protocol that uses keepalives (such as HDLC) but the peer router is configured with no keepalive on the interface.

- no clocking (if the provider is not providing clocking on the circuit but you have configured clock source line).

- and one that I recently ran into - if you configure a GRE tunnel and get IPSec processing using the tunnel protection profile feature, but the crypto negotiation is not successful then the GRE tunnel is line protocol down - even though the circuit may be fine and you have working IP connectivity between the tunnel end points, the tunnel will be line protocol down.


HTH


Rick

Leo Laohoo Thu, 10/14/2010 - 21:30
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

IF the ISP is refusing to check their side, ask them for a loop test.

Actions

This Discussion