Hide Extension of Calling Party Broken after Upgrade to 7.x

Unanswered Question
Jul 20th, 2009


When we were on CCM 4.2.3 I had a requirement to setup a group of our Call Center agents so their extension wouldn't show up. I created another partition and CSS and put them in it. There is a 4 digit translation pattern that allows them to get out to the rest of the users. I set the pattern to over-ride the calling number with their main extension. This worked great, even for IPCCx calls and calls to Voicemail

This worked great until we upgraded to CUCM 7.0. Now when they call on their lines the number shows up as it should but if the call is connected with CCX (Also as ver 7.0) or they leave a voicemail, the calling number shows as their actual extension. Did something change with CUCM 7.0 for this kind of configuration or am I running into a bug?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
carenas123 Fri, 07/24/2009 - 07:35

This can be done by setting the Calling Party Transformation Mask to something like the Main Number on the Route Pattern(s) that are matched the outbound calls.

ecornwell Wed, 07/29/2009 - 09:01

That's what I did for the translation pattern that I use. It works fine for calls but doesn't work on Voice mail or IPCCx calls.


This Discussion