WCS/WLC Bug? Resets Pre-Shared Key in WPA?!

Unanswered Question
Jul 20th, 2009
User Badges:

I've yet to talk to TAC about this as I know they're going to want to test and it's a little hard to test in a live environment but here's my story. Last Friday I had to come into work for a couple of CoW's not connecting and it was very odd. So in troubleshooting I was dinking around with the 4404 controller (5.2.178 code) for that building and looking at settings and made a few changes I'm (sorry not sure what at the time but it was in the WLAN, though nothing related I can guarantee you as you'd have to be an idiot) applied my changes and then I started getting yelled at that all of our carts were dropping connection. They'd attempt to connect but would end up with a Windows error of 'Unable to obtain IP address blah blah'. So I thought it was something to do with DHCP or DHCP settings in the controller. I ended up just shutting that controller down as I couldn't figure it out and was under pressure to get ti back up. The AP's roamed over to my other 4404's and everything worked fine. I left it until today as I was scheduled to go out of town. Well, my two CoW's (carts) were still having problems this morning and I was to look at again.. again, I started doing some testing and holy crap, the same thing happened with my 4404 on 5.2.178 but Controller 2. I took my time this time and looked at the logs and basically was rejecting my authentication so on a whim I decided to copy back in my PSK to the WLAN and walla... they all came back up. AGAIN, nothing was EVER changed with the PSK previously. So what the hell!? Is this a documented bug somewhere? I haven't seen it at all but this is pretty major in my opinion. BTW, WCS version is 6.0.132.0.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
c.yeo Mon, 07/20/2009 - 09:37
User Badges:

We are having the same problem between the WCS and WLCs. I have various codes for the WLCs to see what worked....no version works. We have to go INTO the WLC itself to make changes to WLAN security.

Again, we haven't contacted TAC yet, but hope we hear about a fix soon.

BTW:WCS is at 6.0.132.0, and one controller is even at version 6.0.182.0.


raun.williams Mon, 07/20/2009 - 09:44
User Badges:

I'm glad to see I'm not the only one in this boat. We need an engineer on here to tell us what is a safe version of code to use. To me it's a bit rediculous.

chris.brunt Tue, 07/21/2009 - 01:44
User Badges:

Had the same problem with 5.2.178 but that problem has gone since going 6.0.182.0 on controllers and 6.0.132.0 on WCS. The only way to get the wlan working again for us was to re-paste the psk onto each controller individually. A pain as we have 9 controllers and several wlans on each...


It may be the way that WCS stores keys as we had SNMP v3 setup to the controllers and every time we rebooted a controller it would break the connection to WCS.

raun.williams Tue, 07/21/2009 - 04:26
User Badges:

Did you have any other problems with 6.0.182.0? I hate to go backwards, but I don't want anymore surprises either. I'm afraid to touch anything right now.

chris.brunt Tue, 07/21/2009 - 04:33
User Badges:

No, apart from this

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=Security%20and%20Network%20Management&topicID=.ee6e8c0&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cd4267a


but it's not really a show stopper and v6 is worth it for the improved GUI and we have had a lot less template syncing issues. Stability seems very good so far.

Actions

This Discussion

 

 

Trending Topics - Security & Network