STP Topology Change - Alert Spamming

Answered Question
Jul 20th, 2009

Hello,

We recently setup CiscoWorks and we are constantly (about every 10 minutes, sometimes more frequently) getting notifications of "STP Topology Change". I checked the logs on the switches as well as HSRP and CPU utilization and port utilization. I don't see any evidence or possible causes of Topology changes. We do use VOIP phones. I'm wondering if the fact that all the access ports are actually trunk ports (VOIP and client PC) could be causing these alerts when machines are unplugged or turned off. Has anyone experienced this?

Thanks

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 7 years 4 months ago

This is coming from DFM based on the reception of the topologyChange trap from the switch.

Typically, voice ports are not trunks, but rather one access port which can support two vlans (a primary and a voice). In this case, portfast should be enabled, and topology changes will not occur. For example:

interface FastEthernet0/1

switchport access vlan 30

switchport mode access

switchport voice vlan 20

spanning-tree portfast

spanning-tree bpduguard enable

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Joe Clarke Mon, 07/20/2009 - 11:11

This is coming from DFM based on the reception of the topologyChange trap from the switch.

Typically, voice ports are not trunks, but rather one access port which can support two vlans (a primary and a voice). In this case, portfast should be enabled, and topology changes will not occur. For example:

interface FastEthernet0/1

switchport access vlan 30

switchport mode access

switchport voice vlan 20

spanning-tree portfast

spanning-tree bpduguard enable

end

brianhill88 Mon, 07/20/2009 - 11:34

Thank you. Adding portfast and bpduguard is on the list of things to do in our next maintenance. = )

Actions

This Discussion