SPA 2102, and faxes to the protocol T38

Unanswered Question

(Prefer Alberto Montilla)

Good day!
We test equipment SPA2102 and we have problems in passing faxes.
Fax works only in automatic mode without raising a voice session.
Fax does not go with the reference in the manual mode on a protocol T38.
When I try to connect an error: T38 Decode UDPTL error, enclose a part of syslog.

Syslog, schema and configuration are attached

Thanks

Best Regarde


Max

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alberto Montilla Tue, 07/21/2009 - 07:45
User Badges:
  • Cisco Employee,

Dear Max;


This should work as we have plenty of deployments with the AS5350 and SPA2102 using T38, so I suspect this is a configuration issue.


Are you able to get a network trace (e.g. ethereal or wireshark) so that we see a bit more details?


regards
Alberto

Alberto Montilla Thu, 07/23/2009 - 10:53
User Badges:
  • Cisco Employee,

Hi Max;


Thanks for sending. Will have a look and let you know.


Regards

Alberto

Alberto Montilla Fri, 07/24/2009 - 02:00
User Badges:
  • Cisco Employee,

Hi Max;


Please try the following changes:


(1) On the SPA2102 please change the following:

[Line 1]  FAX Tone Detect Mode: Caller


(2) On the AS5350 make sure the following parameters are set:

fax protocol T38
fax rate voice
fax-relay ecm disable
fax nsf 000000

no vad


Please let me know whether this works. Please test outgoing and incoming faxes.


Regards
Alberto

Hi Alberto,

On the Cisco 5350 settings are:

dial-peer voice 3808102 voip
description ### Test ###
max-conn 2
destination-pattern 3808102
session protocol sipv2
session target ipv4:172.16.53.240
incoming called-number 3808102
dtmf-relay rtp-nte
fax-relay ecm disable*
fax nsf 000000*
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none*
no vad*

At SPA 2102 setup as follows: Linksys SPA Configuration g729.mht

Fix wireshark:

1. in manual mode - is not passed (spa g729 in manual mode.pcap)

2. in automatic mode - has been(spa g729 in automatic mode.pcap)

And the same thing only on G726r32,

Only now, the setting in this mode:

FAX Tone Detect Mode: caller or callee

:

On the Cisco 5350 settings are:

dial-peer voice 3808102 voip
description ### Test ###
max-conn 2
destination-pattern 3808102
session protocol sipv2
session target ipv4:172.16.53.240
incoming called-number 3808102
dtmf-relay rtp-nte
codec g726r32 bytes 40
fax-relay ecm disable
fax nsf 000000
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
no vad

At SPA 2102 setup as follows: Linksys SPA Configuration g726r32.mht

1.in manual mode

2.in automatic mode

Faxes are fine, so would the same thing only on the g729


Best Regards,

Max

Alberto Montilla Tue, 07/28/2009 - 08:49
User Badges:
  • Cisco Employee,

Hi Maxim;


I'm escalating the issue. I'm not sure what the problem is at this stage. As soon as I get a resolution I'll let you know


Regards
Alberto

Alberto Montilla Wed, 07/29/2009 - 08:29
User Badges:
  • Cisco Employee,

Dear Max;


After talking to engineering support, basically our conclusion is that the other end is not responding to the SPA2102 Fax training on manual mode. The SPA2102 starts the training at 9600 bps, no response from gateway, then SPA2102 fallback to 7200, no response, then 4800, no response. I suggest you take a look at the gateway logs to see what's going on, but everything looks ok from the SPA2102.


Regards;
Alberto

Hello, Alberto. 
Forgive me for such a long absence.

We left codec g726r32 until it will work.

There were 2 other problems, I do not know maybe it has already been discussed, but the problem is this: 
1. If linksys close the first port, then the second line does not call. 
2. If you make 2 channel number (ie the first line and a second to register the same number), then the call can be made only on the first line, while calling for the second signal is taken.
This is all at work without registration (ie peer to peer).

Actions

This Discussion